feature or bug with sends


Don’t know if that’s a feature or a bug:
I have a reverb bus in my record and tried to send to it from various tracks. Then I always got the message “connection already made” when I started ardour and my sends to the reverb bus were removed.

However, I found out that the problem was, that I renamed all the sends to “rev” and only one send with “rev” can make a connection to reverb bus (but there was no error message when I renamed the send and everything worked, only at a new startup the connections were lost).

It took me quite some time to find out were the problem was (I renamed the sends to “rev1”, “rev2”, …), so I would suggest to document or fix this behaviour.

(Maybe not to allow to rename a send with the same name as an other send ? or allow multiple sends with the same name …)

LG Georg

PS: on ardour 2.0.3, linux

Yeah, that’s annoying.

Currently all bussing is done via JACK ports which gives lots of flexibility but also some unwelcome limitations.

In the near future, bus connections will be done internally instead of being JACK ports (you will still have the option of JACK ports if you want them)

Here’s a discussion of the new bus routing:

If you have anything to add, please write to that thread.