Fast Track Pro and Ardour 3


I’m totally new to Ubuntu and Ardour. I have installed Ardour 3 beta 3 in Ubuntu 11.10 and I am trying to make it work with my Fast Track Pro. While the system seems to recognize it with no problem (I can listen music throw it with Banshee or Spotify, for example), I get no sound with Ardour and I can’t record anything too. The program plays sounds throw my integrated audio hardware, despite I selected USB Audio at splash screen.

I was a Windows XP user for years and my card worked fine. I have read some post in this forum and tried diferent configurations at qjackctl, but nothing seemed to work.

So, how can I make my card to work again? Can you give some tips to find a solution? Ardour seems a very interesting platform for me, and I’d like to test it!


Here you have some screen captures. Yo can see what I have selected at JACK configuration. It’s in spanish, but I think you’ll understand the pic. I have mounted two images so you can see my input and output devices:

I have tried some other combinations of input/output with no effect.

Also, at Ardour splash screen, I am prompted to select my device from a list of two usb devices. Here you can see:

I have read about this behaviour but it doesn’t matter what I select: it doesn’t work :frowning: I can only get sound throw my internal hardware. And of course, no recording at all!

Thank you!

Thank you for your answers LeatusPenguin, but still can’t get Ardour plays throw my usb card. I have selected my fast track pro from the interface dropdown menu and left the others at default with no result. Also, redownloaded Ardour 2(I tried it before Ardour 3 beta) with same result. I thought my usb card was class compliant so I could use it with no problem. I have tried Audacity and I can play and record with my usb card (but it gave some problems at first, with a very choppy sound that magically disappeared).

Any idea?

Please read the section:

A little bit of boring history and technical explanation

So you understand why I’m forwarding you to that site.


Oops Joe posted at the same time!

You can’t just plug in a FTP and have it work with JACK properly as far as I know, it also requires a module configuration file placed in /etc/modprobe.d/

See this great article it’s for Debian (the base of Ubuntu) but scroll down and you’ll see how create the config file you need:

So are you saying that I must install Debian and compile a realtime kernel and do all the stuff you explain at your blog? Well, it’s a bit intimidating for me as I am a noob at linux distros and I have currently not much free space at disk. I hope to buy a new disk soon. Maybe then I’ll try it.

I saw your article on these past days while looking for a solution, but I thought that it was intended for achieve a 24 bit-96khz recording. I used my card for amateur recordings and initially don’t mind about bit-depth. But the problem now is that I can’t use it at all! :S

GMaq: I tried downloading that config file and follow its instructions, but didn’t work. I think I must do all the previous steps, it isn’t?

I thought that there were people out there using this usb device with ubuntu and no problems. Maybe at a wonderful world…

You don’t have to install Debian or compile a realtime kernel.

I can work realtime with rt-patches with my multiface interface.
If you start jack with realtime option enabled. Do you see in the main window of qjackctl ‘RT’ blinking? In that case realtime is working.
It’s been a while since a just a patch realtime kernel, because the kernel already has some realtime options, but it’s not yet completed.
I can perfect work with 5ms latency.

Now the latency has nothing to do with your problem of getting no audio in or out.

Have you tried with the input 1,0(usb audio) of 1,1(usb audio 1#)?

Did you select input’s on the channels?
Is the master connected to your outputs?


For the record AV Linux has all of Joe’s tweaks in the blog including 24bit support all completely done for you out of the box. I can’t speak for Ubuntu, but we have several FTP users who have the device working on the AV Linux forums.

If you can’t get it working on your current setup you can try it with an AV Linux LiveDVD and see if it works.

Many thanks to Joe for an excellent tutorial which has helped a LOT of FTP users over the years!!

It seems that there is not hw:Pro,0 capture device, so hw:Pro won’t work either. You have to enter hw:Pro,1 as the input device, and hw:Pro,0 (for outputs 1 and 2) OR hw:Pro,1 (for outputs 3 and 4) as the output device.

The above should work with the standard driver in ubuntu 11.10 but, again, note that bit depth will be 16. For a better ardour experience, try AVLinux.

By the way, if you try AVLinux DVD with a spanish keyboard, make sure you run this command:

setxkbmap es


The master is connected and I can select between two inputs, but they are the inputs of my integrated hardware. When I select them, a light noise becomes visible through the channel meter, so its working, I think. But not with my FTP. No matter which input and output I select at Jack, the result is the same. The same with Ardour’ splash screen, where I must select between USB Audio or USB Audio #1. And when I hit the play button, sound always come from my internal hardware. Should I deactivate it somehow?


AV Linux seems an interesting option, but I’d like to have more disk space before trying new OS installations. I need a new disk because this one has no much free space. However, the ‘AV Linux LiveDVD’ confuses me: can I try it whitout installation, from the DVD or USB just like regular Ubuntu, before installing it? And what about Ubuntu Studio?


As I said I tried every combinations at Jack and Ardour splash screens with no result. You said that the combination you mentioned work with the standard driver in ubuntu, but not for me :S

Thank you all. I’ll keep trying it some more times! :wink:

If you use Ubuntu studio you’ll probably have the exact same issues that you have now with plain ubuntu. Ubuntu studio = Ubuntu (period).

AV Linux on the other hand is debian with custom compiled kernel and I believe it has my patch or tweaks (thanks GMaq) and will work better. My point here is stay away from ubuntu for pro-audio.


Yes you can download the AV Linux ISO image and burn it to a DVD just like you would try Ubuntu. Also you can take the AV Linux ISO image you downloaded and use Unetbootin to create a Bootable USB Key which will work much faster for you. I certainly don’t expect you to install it or make any changes to your existing system until you try it for yourself and see that it works with your fast track pro.

I will say that AV Linux LiveDVD is in English although as Pablo said you can change the keyboard layout while you are trying it.

You can find the ISO image here:

Ok, downloading the ISO. I’ll try AV Linux and I’ll tell you if it works. Thanks.