Failed to register port “Click/audio_out 1

(Ncldjr2) #1

I’m running Ubuntu Studio 18.10. In Ardour 5.12.03, when I close a project then try to open another one, I get an error message that says “unable to create port: failed constructor. Click the Close button and try again”. The only way for me to open another project is to close then reopen Ardour. I tried deleting the instant.xml files, but that did not seem to help. I renamed the /usr/lib/ladspa directory to /usr/lib/ladspa_old so I’ don’t think that the ladspa plugins are a problem. No control surfaces are checked. I think that Ardour is set to handle many more tracks than I have. I get the same result if I disable plugins and try to open another project. I even went so far as to completely reinstall Ubuntu Studio 18.10, thinking that I installed some app that messed up Ardour. Still no luck. If I archive some of the projects, then open them on a virtual machine running Ubuntu 18.10 (on another computer), I don’t have a problem. If I create a new file with only two mono tracks and the master (no signal, no plugins), Ardour still crashes. If I start Ardour with a line command, I get “Failed to register port “Click/audio_out 1". Any thoughts? I asked this question a few days ago, but thought that the error message I saw in the terminal (and as the topic here) would be a more useful starting point.