Failed to Instantiate lv2 plugin for Pianoteq 8 STAGE

Hi boys and Girls.

So, I’m using Ardour 6.9.0~ds0
“After Bach”
(rev 6.9.0~ds0-1build1)
Intel 64-bit

Running on Linux Mint 21.3 Virginia, on a Lenovo Thinkpad x230 i5.

I recently purchased Pianoteq 8.2.2 STAGE which works perfectly as standalone app.

However, having installed the x86-64bit lv2 in my local .lv2 folder, it seems Ardour doesn’t want to load it :
2024-06-05T20:02:12 [ERROR]: LV2: Failed to instantiate plugin
2024-06-05T20:02:12 [WARNING]: Failed to add Synth Plugin to newly created track.

any clues?

I was previously using Pianoteq 4, that works OK but only an x386 was supplied back then.


Chances are that this distro is too old.

Run Ardour from the commandline (open a terminal, run ardour6) there may be more information shown there.

Also try a recent Ardour8 (demo is fine can be installed in parallel to distro builds).

Too old? Virginia was released Jan 2024.

Command line didn’t tell me much - apart from a few error messages about Pianoteq v4, which oddly enough, works OK. I might try removing it to see if that helps.


OK. 21.3 and Ardour 6 threw me off.

I thought it was released in 3rd quarter of 2021 which also matches Ardour 6.9’s release date (August 2021).

It’s based on Ubuntu 22.04, which was released in April 2022

It’s a fair comment, and I guess there could be some clash between the latest plugin library version and older-compiled versions of Ardour.

I see that Modartt (makers of Pianoteq) have some older versions available, I think I will try some of those and see if they work better.

I’ll keep you posted!


FWIW, the v7.05 version I bought some years back still plays flawlessly for me on AVL MX 21.3.

Also FWIW, I’m running Mint 21.2 and can confirm the Failed to Instantiate LV2 for Pianoteq 8.2 STAGE for Ardour 6.9, though it runs fine in Ardour 7.x and 8.x.

I just loaded up an old project created with Ardour 6.x, and it looks like I was using Pianoteq 6 successfully back then (circa Feb 2021). I no longer have that installed so I tried replacing it with Pteq 8.2 STAGE and sure enough it failed to load.


Any lines at which might be interesting just prior to the one you quoted?

UPDATE: I tried one of the older Pianoteq Plugins, v7, that works fine in Ardour 6. I guess I will live with that until I install a more up-to-date version of Ardour.
Thanks for the suggestions everyone.