Failed building Ardour3 on Debian Powerpc

I’ve downloaded the released sources of Ardour3 and tried to build it on Debian wheezy powerpc.

waf -configure doesn’t seem to recognize this platform . See below :

Checking for header boost/weak_ptr.hpp : yes

  • Build documentation : False
  • Debuggable build : True
  • Install prefix : /usr/local
  • Strict compiler flags : []
  • Architecture flags : None
  • Aubio : True
  • AudioUnits : False
  • AU state support : False
  • Build target : i686
  • CoreAudio : False
  • Debug RT allocations : False
  • Process thread timing : False
  • Denormal exceptions : False

and the build failed here :

[294/770] cxx: libs/ardour/ -> build/libs/ardour/
[295/770] cxx: libs/ardour/ -> build/libs/ardour/
…/libs/ardour/ fatal error: xmmintrin.h: Aucun fichier ou dossier de ce type
compilation terminated.
Waf: Leaving directory `/home/bertrand/Documents/Programmes/ardour-3.0/build’
Build failed

xmmintrin.h doesn’t exist in gcc-powerpc. So I’m stuck.

Any idea ?

we used xmmintrin.h on the understanding that it was a basic part of the gcc compiler suite. if it isn’t there for the powerpc port, then sure, ardour won’t build. but i would really be surprised by this.

Thanks a lot for your quick answer.

This file is present in gcc-4.6 for i386 (see ) but not in gcc-4.6 for powerpc ( see There is altivec.h (instead of it ?).
xmmintrin.h is present in clang : /usr/include/clang/3.0/include/xmmintrin.h

Maybe can i build with clang. I don’t know how to do.

But this message “* Build target : i686” when runnin ./waf configure, is strange.

I’ve just tried to “ln -s” this file (/usr/include/clang/3.0/include/xmmintrin.h) into my gcc headers. Build failed to but with this message :
[295/770] cxx: libs/ardour/ -> build/libs/ardour/
In file included from …/libs/ardour/
/usr/lib/gcc/powerpc-linux-gnu/4.6/include/xmmintrin.h:28:2: error: #error “SSE instruction set not enabled”

that is never going to work. this file typically involves architecture-specific assembly language.

someone who cares about PowerPC would need to find an alternate way to provide the functionality that Ardour uses from xmmintrin.h

That’s what I thought. But I am not able to find this alternate way.
Thanks for your help.