Faders not working?

I’ve got a fresh install of Ubuntu Studio 10.04 as a dual boot on my 21.5" iMac. Things seem to work fine except for the faders. The audio level does not change when I move the faders until it gets to -inf and then it mutes as expected. I’ve been using Ardour for many years now usually with a pc and a delta 1010. This is just the factory iMac soundcard. I’ve never had any issue like this. Any help would be greatly appreciated.

Ubuntu Studio 10.04
Jack 0.3.4
Ardour 2.8.6

Well I’m running the same versions on an old machine (pc) with no issues. I’m not a linux wiz. I started out on Fedora and then later went to ubuntu studio. I’m always open to trying new things, but would prefer not to have to do too much terminal work to get machine working. Suggestions?

My suggestion is to use a package from a source other than the Ubuntu Repos. Look around, I think Dick Macinnis has a repo set up you might try IIRC, but check on this before you try it.


This problem persists. I have now also tried Fedora12 and get the same result. Faders do not change level until mute. Mute buttons do nothing. The sound I get is very distorted. Alert tones sound fine without jack but hydrogen distorts with or without jack. I really think this has to be the way things are configured for the imac sound card, because it all works fine on my p4 with a delta 1010. The imac has an nvidia card. Any ideas?

Absolutely Agree, but I’ve tried Ubuntu 9.10 and 10.04 and Fedora 12 and I get the same problem in all these builds. I don’t mean to point fingers at Ardour. I’m sure thats not where the issue is, it’s just where I can see the symptoms. I just have no idea where to begin looking for a fix. I can get around a terminal but I’m not an engineer. I’ve tried my usual haunts and came up short. Maybe my imac is just too bleeding edge?

I used to have a problem that was almost the exact opposite of this. I would write some fader automation. When I played it back, the audio level would change but the fader (graphically) would not move. Again, it could be solved by fading the audio right out to zero - after which it would start working normally. I can’t remember now whether it only affected one particular release or whether it just sorted itself out after a full rebuild. Unfortunately, it doesn’t sound as if you’re building Ardour from source so if that was the solution, it probably won’t help you much. :frowning:

@thompsonist: ardour’s fader operation have absolutely nothing at all to do with your audio interface. you could be running ardour with jack using the netjack backend, and the faders would still operate in precisely the same way. there’s an extremely odd problem with your build.

@thompsoninst: this has never been reported before and I personally suspect a problem with the Ubuntu build. For reasons unknown the Ubuntu builds of Ardour have often been afflicted with issues that don’t affect other distributions or people who build Ardour themselves.