extreme xruns

Hello everyone,

I’m trying to setup my Macbook pro 3.1 (early 2008/late 2007) as a mini home recording studio. I never got into Apple’s Logic and nor do I have the money to spend on it. After using ardour in linux for a little bit (on the same machine, dualbooting on ubuntustudio and 64studio) I have decided that I would really like to keep using it but on Mac OS X 10.5.6 for various reasons (ACPI, backlight poorly supported in either ubuntu and 64studio, difficulty with wireless, instabilityi ubuntu studio).

However, I’m getting a lot of xruns when I open and try to record in Ardour for more than five miuntes at the time. I have the latest JackPilot and jack os. When I set them to the ‘512 buffer size’ at which they work fine under linux, ardour just goes crazy with xruns. However, those xruns are not present when I run jack by itself. For example, I have even set a buffer size of 32 for laughs and giggles and routed my captures into my playbacks and played guitar and I could hear myself very nicely on the Mac’s speakers without any xruns or delay. Not only I was able to do that, but I also ran garageband through Jack at the same buffer size and used some of its effects on a track (while also monitoring and recording it) and heard only few xruns. With Ardour, everything is unusable at any buffer size.

I would really like to use Ardour on Mac os; it is so much better than Garage Band. If it would just work…

Any ideas?

My configuration is this: Core Duo 2.2ghz, 2gb ram, nividia 9400m, behringer U-control USB card (the cheap 40$ one). Please help me. I have tried running Ardour from a terminal in mac os to see any interesting output, but there was none.


Problem solved. For some reason Ardour didn’t like the specific project I was working on. I created a new ardour file and everything works. I also updated Mac OS, might have helped too.