Extreme system load compiling ardour 2 from svn

I tried to build ardour2 ongoing from svn on Suse 111 and on Ubuntu 8.10.
In both the process generated enough system load to hang the entire system. As of now I behold the monitor of my workstation that runs ardour-projects with 50+ tracks and 30+ plugins with ease and everything got stuck. Yesterday on my laptop with suse 111 scons made the machine hit the 90degree centigrade borderline…

Anyone else out there having similar problems?

I used to have these problems, until I found out that my swap space was misconfigured. I added swap ("/sbin/swapon") and it did no longer grind to a halt but just got real slow instead… compiling ardour hogs some serious memory. If it starts paging, it’s like running emacs in 1992, if you remember that.

Now I bought another 1GB DRAM (adding up to a grand total of 2), it’s all much smoother. I can still do emails or something while a compile is running, though with the CPU at 100%, i can’t expect any compute-intensive tasks to work very well.

I think 1-1.5GB should be enough. I’ve compiled Ardour on this laptop that has 370MB w/o too much of a hassle, though you might want to make sure you don’t have anything else running that’s chewing RAM.
And you also might want to avoid running scons with any -j parameter.

I’d look into Pauls suggestion and check the scons version. v1.0.1 and 0.98.5 with python-2.5.2 works here.

Although its likely just a lack of memory (compiling template-heavy C++ code is extraordinarily memory consuming), there were also problems with older versions of scons that made them eat all memory available on the machine. I doubt that this is still likely to be a problem.

Notice that you provided absolutely no information about your machine when reporting this. The ability to run as a DAW versus as a compile engine are (sadly) very different. While writing this, I have a 3-way parallel compile of ardour in progress, the CPU is pegged at 100%, and I have a 64 bit system with 2GB of RAM (equivalent to 1GB for a 32 bit system). It just works.

intel 32bit board
core 2 duo E6600 proc
7200 RPM SATA2 disks (data with XFS, OS with ext3, I compile ardour from an XFS partition)

debian sid, kernel

scons -j 4 : takes 13mn, linking causes no trouble.
Not that I want to show this off, but having dealt with low resource systems in the past, I did not want to end up with this kind of problems, i want to spend as little time as possible in compiling, upgrading, etc. It’s a prod oriented machine.


I’ve had this problem twice recently. Try deleting all the scons cache files:
rm -rf .scon* (from within the ardour source folder)

This fixed the problem for me.

(edit: I’m assuming that scons used to work and now it is slow. If this is your first attempt at building, then this probably isn’t going to help)


Thanks for the hints, I had some doubt regarding my memory-ressources before.

Its 1.5 GB on the Laptop (AMD64 X2, MSI-Cheapo)
And 1 GB on the Workstation (AMD Athlon 64 3800+)

OK- one more reason to upgrade to some 4 GB…
Or are there any workarounds(scons-options etc)?

Thanks for the hints :slight_smile:

I now managed to solved all the hassle and the only likely explanation seems to be BenLoftis one. Having the build process running without great extra load in a freshly fetched SVN-checkout did not used more then 400-500 Mb or so on my puny laptop. The same in 64studio3.0beta on my bigger box.
On the latter scons is v0.97
On the laptop with suse111 it is v1.1.0

btw: the build works like a charm - no issues seen so far…