External project drive

Ardour sees a ghost. Ardour has been good about creating a new session on my external drive within the Ardour folder I created but lately, saving is making a ghost project folder within my Ardour folder on the drive. It claims it’s there when I try to do a save as and It states that folder already exists. OK, then where’s my project at? I checked system, desktop, music, documents, pictures, videos and downloads. Did a Save As and it sees the parent folder and I click parent directory folder and then other and put the path to the actual parent folder just in case and no change.
Ardour Save As
Ardour Save As2

Can you rephrase your question? It is not completely clear what exactly is happening, versus what you expect to happen.

The second screenshot shows an HDD folder, so what happens when you double click on that HDD folder and view the files under that directory name?

When I double click HDD it opens the folder which is still no where to be found other than what it offers. When I click on HDD.ardour to open the project, it’s an empty session which had 5 tracks of audio. I click on the interchange folder where the audio files should be and it’s empty. So Ardour claims there is a session folder at /media/davidhelms/SILVER 1T/ARDOUR/ . There is a session folder somewhere just not where it says that it is. So I did a “catfish” (Linux) search for the Ghost Folder on the external drive where it should be and claims to be and it’s nowhere to be found. Do I need to uninstall and reinstall?
I hope I explained it better.

If you are opening the session from Ardour’s initial “Session Setup” window by clicking into the built-in file manager under “Other Sessions” (which opens a separate window labeled “Select session file”), the ‘audiofiles’ folder within the ‘interchange’ folder tree will appear empty because it only looks for Ardour Sessions or Session Archives, not audio files. Audio files within the interchange folder tree are viewable if you open the folder from your desktop file manager, which is Thunar on my computer. I can view them by navigating to: [Ardour’s parent directory]/[session name]/interchange/[session name]/audiofiles.

Rather than searching for the folder, what happens when you search for the session file using Catfish, i.e. ‘HDD.ardour’? I haven’t used Catfish before, but I assume there is a way to search the entire computer at once, including the external drive.

With your external hard drive attached and regardless if Ardour is running or not, what do you see when your open your desktop file manager, click on “File System” in the left column and open the “media” folder? I would expect you to see a folder named “davidhelms”. Inside that folder is there one named “SILVER 1T”, and inside that one a folder named “ARDOUR”, or are they missing? If this location is what you set as your parent directory for saved sessions, that is where they should be.

Something peculiar I noticed is the full written path does not populate in the Location bar when I am in the “Select a File” window, only the name of the selected folder. I don’t know why that is different on mine compared to yours, but I am assuming it auto-populates on yours to show the path to the parent directory and isn’t there because it was typed by you. I am using 7.5 downloaded from this site installed on Debian 12.

After creating a new session, the “Save As” window only has a box to type in a session name. It is not until you “Save As” inside a session that has already been saved that the window in your screenshot appears. Is it possible you accidentally overwrote the session that had 5 audio tracks by not renaming it after some irreversible changes?

It isn’t clear to me what you mean with some of your descriptions. I am doing my best to put it together but am making some assumptions. For example, I don’t precisely know what you mean with the phrase: “the folder which is still no where to be found other than what it offers” or if by “Ghost Folder” you mean the session folder named ‘HDD’ or something else. I’m sure there are people on this forum who can provide you with some answers or insight, but the more specific you can be, the more likely you’ll receive help. I would start with a Catfish search for the session file rather than the folder to see if that program can locate it, and also navigate to your external drive’s folder tree where the Ardour parent directory should be to see if it is there. It won’t be in Downloads, Pictures, Videos, or any other location than the one you selected for it.

I apologize, I just get long winded and descriptions in my head have a tendency to run a hierarchy that I see but hard to describe. Let me try this… Thunar side bar/SILVER 1T/ARDOUR/ (HDD session not there). I just checked older sessions by clicking the .ardour item in that folder and that session has audio files but Ardour only opens empty sessions. When I open Ardour from the start menu, I click on “Other Session” it does not see my external drive SILVER 1T. When I use “Select Session File” the external drive SILVER 1T is not listed so I use the search option at top of list on the left and copy the path from Thunar to the ARDOUR session folder on that drive and it does not find it. The external drive is formatted FAT 32 and has been that way for 3 years so I can open session on other computers including a MAC that has Ardour and they open fine there…(justed tested). While connected to my Linux machine, Other files on that drive, various audio files, pics and a few videos open just fine. I hope I did a better job this time of making sense.
I appreciate your patience.

Those words have no technical meaning, so it gives no way to understand what is actually happening on your machine.
Helpful words would be things like “directory name exists, but there are no files in the directory” or “I can find these files but Ardour does not display them in the session chooser dialog box.”

That is a logically inconsistent statement. How can a folder be available to click in the file browser, but still be “no where to be found?”

No we are getting somewhere. A file with a .ardour extension is an Ardour session file, so Ardour did save the session, but it apparently does not contain the audio data you expected.

Show a screen show of a file browser (dolphin, nautilus, etc.) in that folder, or open a terminal and navigate to that location and run the ls command to list the directory contents.
Using a terminal has the advantage that you can copy and paste the text, you do not have to deal with cumbersome screenshot tools which can only show a page of information at a time.

Yes, and you have proven that to be the case by showing that there is a .ardour file there.

But you just showed it was there in an earlier post. Did you unmount the external drive by mistake?

Ardour requires a case preserving file system, and FAT32 drives are known to cause problems because of that.
See this posting for a discussion:
What format is best for external drive

tl;dr If you need cross platform compatibility then exFAT is likely the best choice. The lack of case preservation may be what is causing you a problem with your FAT32 drive.
You can verify that by using a file browser or terminal to actually look in the /media/davidhelms/SILVER 1T/ARDOUR/HDD directory and see if there are wav files in the interchange directory.

1 Like

I see. I think I understand the problem now, but unfortunately I have no guess about what is causing the session to open in Ardour on Mac but not on Linux. The external drive functioning normally on Linux outside of Ardour would seemingly rule out a system or hardware issue, and if the session opens as expected in Ardour on Mac that rules out an accidental overwrite. That’s a head-scratcher. Perhaps un-installing Ardour, removing the desktop files by deleting the “ardour7” folder in ~/.config, and re-installing Ardour will correct whatever is wrong, but only take that advice if you are comfortable trying it out.

I just saw that @ccaudle responded. He is much more knowledgeable on this stuff than me, so if he thinks the FAT32 file system is potentially the culprit, I would consider what he has to say about that variable. If it is an issue with the external drive’s file system, it is probably less likely that the un-install/deletion of desktop files/re-install of Ardour will correct it.

I want to thank you and @ccaudle for all of your help. I really am grateful there is a forum with patient helpful people and I will do the production on my MAC for now till I get a chance to remove Ardour, get an extra drive and format either xfat or straight up Linux ext4 so I can avoid hopefully any future problems. I know just enough to break it and patient enough to fix it.

There is no reason to remove Ardour (assuming you installed into the default location and did not install Ardour onto the external drive). Can you explain why you even brought that up?

I would need someone with access to a Mac to check, but I would assume that MacOS could potentially have the same problem.

I don’t know if you read all the way through that other thread I linked, but a different more cumbersome method you can use is to use the session on an installed disk, and when you want to move to a different system zip the session folder to a zip file on the external drive, and then unzip from the external drive to an installed disk on the other system. Takes more time, and you have to keep track of which system has the latest version of the session, so definitely not ideal.

There are other ways to get there as well, for example using network filesystems to copy sessions between systems in the same building (not recommended over long distance network connections, the audio files are just too big).

So just out of curiosity, I did uninstall Ardour 7.0 and upgraded to 7.5 and old projects are working again though I’ m not even worried about the session named HDD because it’s no where to be found. After reading at the links given, I’ll backup and format the USB drive to ext4 and an use a thumb drive or network connection to my Mac if I need to do work on projects there. I do appreciate all of your help and look forward to learning more about Ardour since I’m doing most of my production on Linux now.

I’m not sure why you keep saying that, as I pointed out in a previous reply you have shown that it is in the HDD folder where it should be (although you never did show the directory contents as suggested to verify that the audio files are a reasonable size).

You can likely recover that session by moving it to a different filesystem and fixing up the filenames if necessary.

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.