External MIDI keyboard connection with MacOS

I’m new to ARDOUR, and DAWs in general. My initial need is to use Peti VST on my MacBook Pro (MacOS 10.14) with external MIDI keyboard (AKM320). I got Peti (harmonium synthesizer) installed in Ardour5. It works fine with its software keyboard, and I’m very impressed with the overall design of Ardour, but I can’t figure out how to make the external keyboard work.

I appreciate that Ardour has reasons for using external software for this, and have installed MIDI Patchbay and MIDI Monitor per Ardour docs. But these docs provide no specific instructions to make this seemingly straightforward connection, and the few related forum posts don’t seem to directly address this and are quite dated.

I first tried several other DAWs that wouldn’t or couldn’t support this VST, though they all recognized the external keyboard. I got Peti to work with this keyboard using Tracktion (but don’t want to continue using that for several reasons). So, there seems no problem on Peti’s end, and the keyboard works.

Any help greatly appreciated!


You don’t need any external software for this. Are you perhaps using Ardour with JACK? There’s no particular reason to do this - just tell Ardour to use its own CoreAudio backend, and select the CoreMIDI support too. Your device should just show up.

Nice to know external software isn’t needed, but where should my device show up? I’m using the standard Ardour install and have no knowledge of JACK, so it’s not involved unless it’s a standard part of OSX 10.14. I don’t see CoreAudio or CoreMIDI in my fairly thorough poking around the Ardour gui.

I attach a screen shot of the MIDI connection Manager. My keyboard is an input device only, if that helps.


Take a screenshot of the Audio/MIDI setup window (the one inside Ardour, accessible via Window > Audio/MIDI once running, or the one that shows up when you start Ardour).

I notice CoreMidi in the drop down at bottom. Before starting it’s active and shows None as the only other option.

Does the device show up in the system’s Audio/MIDI setup window ?

Doesn’t seem so. I attach the screen shot.

Perhaps importantly, when I took the earlier MIDI Connection Manager screenshot I mistakenly didn’t have the keyboard plugged in. With it attached, the Ardour Misc Source to Destination tabs looks the same as before, but there are now Hardware tabs. I’ve tried all I believe of the new connection possibilities without luck. And will attach shots in subsequent posts, as I’m limited to one each.

Your patience is much appreciated!

Now I see my keyboard in the MIDI Patchbay window and in the Audio MIDI Setup window: see this large screenshot. After restarting Ardour it still doesn’t work, and the MIDI Connection Manager options look the same. But anyway, this seems like progress.

Your keyboard is present inside Ardour, but not very well labelled. It is called “System”.

This has been improved in the development code, and therefore in the next release.

It should show up with proper name in mixer-strip input selector dropdown already in 5.12

It’s working! right-clicked on track name (Audio 1) > Inputs… pops up Audio 1 input dialog, with Hardware source selected. Clicked system.x.1 intersection for green light, and system-1.x.Audio 1 in mono selected also. Trimmer to right does nothing.
0 element below has to have rt-click 01 box checked. Clicking it toggles blue to invert: doesn’t matter.
right-click on new element that appeared below it shows midi_in 1 < systemd:midi_capture_

Not at all obvious, and the documentation seems to deal with a very different version of the system. But very happy to have it working, and thanks to both of you for your assistance.

This all sounds a bit confused. Audio 1 is an audio track (overwhelmingly likely). Connecting your MIDI keyboard to it doesn’t make such sense. That’s why only “system:audio 1 in” is shown in the menu for that track.

MIDI 1 however is a MIDI track (overwhelming likely), and connecting it to that does make sense. That’s why “system:midi_capture” shows up in the menu for that track.

The options for an audio or MIDI track do overlap a bit, but they are also quite different in many important ways.

Quite so. I got off on the wrong foot by selecting an audio track. I’ve just created a new project with a MIDI track instead and it’s pretty straightforward. Many thanks for the clarification.