External MIDI and audio problem!

My Access Virus C has 3 stereo audio outputs and is configured as follows:

midi ch. 1 = audio OUT 1 L+R : this port is going OUT from Virus and IN to my audio interface ch.25-26.
midi ch. 2 = audio OUT 2 L+R : this port is going OUT from Virus and IN to my audio interface ch.27-28.
midi ch. 3 = audio OUT 3 L+R : this port is going OUT from Virus and IN to my audio interface ch.29-30.
All 3 MIDI tracks in Ardour has their channels set to output to VIRUS 1,2,3.
All 3 AUDIO tracks in Ardour has the correct inputs, AUDIO 1 input 25-26, AUDIO 2 input 27-28, AUDIO 3 input 29-30.
The problem is that midi ch.1 is OK ,but ch.2 and 3 is playing on ch.25-26 (AUDIO 1)in ARDOUR instead of ch.27-28, 29-30.
Exactly the same routing is working in Cakewalk by Bandlab, but I rather work in ARDOUR, I like it a lot.
Any ideas?

You will need to supply quite a bit more information for someone to help.
What audio interface? Does it have internal routing that might be mixing channels together?
What operating system? Since you mention Cakewalk can I assume Windows? Or are you using MacOS?

Can you post a screenshot of the audio routing window in Ardour?

I apologize, forgot to mention that I am on Windows 10 and should have selected the Windows group.
I am new to ARDOUR and I like it very much.
My ADA is FERROFISH A32, and sound card SSL-MADI-Xtreme64.
Attached routing pictures.

Sorry , wrong picture on the midichannels, here it is as it should be, but still the same problem.

Ferrofish inputs in the session

Ferrofish routings

Based off your screenshots, it looks like the Virus is not generating audio on the inputs to your Ferrofish as I only see audio input on 25-26. Can you test one Midi Channel Out at a time, and confirm that Midi is going out from Ardour, getting to the Virus as expected on the appropriate channels, and that the virus outputs show up on the correct inputs on the tracks in Ardour?


I suspect that your problem is that you believe the buttons saying “Channel 1/2/3” control the channels used by the track; they do not. If you mouse-over the button, it says “MIDNAM Channel Display”. It has absolutely no effect on the MIDI data sent or received by the track.

My guess is that all your tracks have MIDI events on channel 1 and thus the Virus outputs the 25/26 for all of them.

1 Like

Well…that sounds interesting, I think I have to figure out how to route the midichannels to VIRUS then.
Thank You very much.

+1 to Paul, and where i was heading towards, just taking a longer way to get there to demonstrate the routing of Ardour along the way.

MIDI Channel Map plugin I think may be useful in your case.


I think that there is no need for a plugin to do this.
ARDOUR has a very flexible routing system so I do not understand why this is not working.

MIDI Track 1 OUT 2 ch.1
MIDI Track 2 OUT 2 ch.2
MIDI Track 3 OUT 2 ch.3

Why is this not working? Only ch.1 is OK.
This is how I do it in other DAW:s
Maybe ARDOUR do it different, but how?

As Paul mentioned, it is likely because what you are looking at on any individual tracks is ALL MIDI Data, not just what is chosen by the selector. This is different from what many people are used to from other DAWs I believe.

I would still suggest you answer my question above, as that is the start of following your signal routing through to confirm this is the case or not.

1 Like

You have described nothing that would ensure that Track 2 and Track 3 use MIDI channel 2 and 3 respectively. You have been misled by the “Channel 2” text in the button, as I described.

You can force MIDI data to a given channel by right clicking in the track header, choosing “Channel Selector”, then in the playback section of the dialog that appears, pick “Use a single fixed channel for all playback” (and make sure you pick the correct channel).

Or you can make sure that the data in those tracks uses the correct channel to begin with.

1 Like

Everything is working now, happy end.
Thank You Seablade for understanding people coming from other DAW:s and thank You paul for suggesting the channel selector.
This was new settings for me and now I know Thanks.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.