Exporting sessions...converting files...help!

*I’m a total noob here.

When I export a session as a WAV, the file seems totally useless. I can’t use audacity to convert it to an mp3 and it doesn’t play in anything I try to open it with. Am I missing something?

Well, for the problems you have been facing regarding the wave files and the mp3 ones. What you can really do is, firstly play the wave file in a software, which can play wave files as well. Then probably you’ll need a moniter recording software, I use the BitRope Recorder 1.3.13, what it does is records whatever’s playing in the background, make sure you turn your messengers to the offiline mode, cause if they make any sound that’s going to be recorded as well. And when you’re done, you’ll get an option to save the file in other extensions too.

Note: It is better if you put on headphones while you record the background music, it’ll help you figure out if there is any unwanted sounds recorded along with the song.I use the Klipsch headphones, when ever I’m working on some sound waves.
Gd day.

Really… you choose to spam software for the one platform that Ardour doesn’t run on in its forums huh? Not to mention you obviously don’t know the first thing about Jack and how it works given your advice:)


Probably, what settings are you exporting at? Easiest way to see would be to post a screenshot via tinypic or whatever.


i’m having the exact some problem, trying to open my files in itunes or audacity no luck so ill hang around this thread too

did you try to reimport in ardour to check it again ?

and what does the following terminal command say about this file:

sndfile-info your_wave_file

when i re-import the track into ardour it has no sound.

when i use that command it says:
Version : libsndfile-1.0.20

Error : Not able to open input file /home/caytee/nhlkj/export.
File : /home/caytee/nhlkj/export
Length : 4096
Error : psf_fread returned short count.

File contains data in an unknown format.

hi caytee, not sure I understand your command line. What is the name of your file ? shouldn’t it be “export.wav” ?
Moreover, it looks like (if sndfile-info really tried to open the file) that it is broken.

EDIT: no, it’s not broken. You applied sndfile-info on the directory which spits this error message consequently. Use sndfile-info on the WAVE file :wink:

umm, when i use it on the wave file it says no such file or directory.

@caytee, it would be nice to have more details. It looks to me from your posts that the export file does not exist. Are you sure your export went well, and ardour created a WAVE file (by default, it is “session”/export/export.wav) ??

I suggest you try to export your session one more time.

Did you remember to check the little master:out left/right boxes in the right frame of the export window? The color selection makes in almost invisible on my CRT screen, so if I didn’t know it was there I’d miss it.

In that case you’d end up with a perfectly fine wav but only containing silence.


And of course copy and pasting your terminal commands and their output may help as well since it does sound like you are misusing the sndfile-info command. Surround any such copy and paste with the CODE tags so that they are easily legible please.


There’s been a problem with exporting from a 48kHz session to 44.1kHz 16-bit .wav file for a while now on my systems. If the export dialog window disappears immediately when the export button is clicked, the export hasn’t worked. The file is created but there’s no audio data in it.

The workaround is to keep trying. Until the export progress bar can be seen working, the export is not working. It usually works here after two or three attempts, but sometimes takes more.

The problem only occurs when exporting to a different sample-rate/bit-depth from the session. I haven’t had time to look further into it yet, but I’d be surprised if I was the only one experiencing this. It’s been happening on the last few Ardour versions up to and including 2.8.7 (haven’t tried newer ones yet).


Haven’t had that problem in a while personally.


It’s nearly 100% reproducible here.

After mixing down a multitrack 48kHz session to a stereo track, I right click on the lower bar of the track and use the menu -> sub-menu to export it. Settings in the export dialog window are 16-bit 44.1kHz, little-endian .wav, at best quality with triangular dither. The destination directory is the one above the session.

The first attempt nearly always fails, with the export dialog window disappearing immediately when the export button is clicked. Usually the second or third attempt is successful, indicated by the progress bar operating. Sometimes it takes more attempts.

The system is a dual 2.2GHz Opteron running Debian 5.0.4 amd64 with a non-rt 2.6.29 kernel with pre-emption enabled. There’s nothing wrong with overall performance and apart from the export problem it’s very reliable. IIRC my other system with a 2.5GHz AMD64x2 does the same thing, but I’ll have to confirm that the next time I set it up. I suspect a race condition is being triggered by my particular setup, but I’ve been too busy to look at it more closely.

errr, so i think i am using the command wrong because i don’t understand what the “name” of the file is or how you are supposed to write that into a command.
but anyways, here is what i did:

sndfile-info /home/caytee/nhlkj/export.wav

Version : libsndfile-1.0.20

Error : Not able to open input file /home/caytee/nhlkj/export.wav.
File : /home/caytee/nhlkj/export.wav

System error : No such file or directory.

also, i tried exporting it a second time based on what jrigg is saying, and the first time the export dialog window disappeared as soon as i hit export…so i tried it again and it seemed to work (there was a progress bar and it took a few seconds), and the file looked different this time in audacity (but still seemed useless in anything else i tried to open it with) and i could actually export it as an mp3 from audacity, but it still wouldn’t play in audacity and the exported mp3 was once again useless.

@caytee:It looks like there is some confusion as to where you have told sndfile-info to look for the export file:

The file you need to point sndfile-info at is called export.wav and it (confusingly) lives in the ‘export’ directory, so normally the path is “session name”/export/export.wav (as thorgal said) e.g.


I think previously you were running sndfile-info on /home/caytee/nhlkj/export which is the directory - hence the error, and then recently you are running it on a non-existent path e.g. /home/caytee/nhlkj/export.wav instead of /home/caytee/nhlkj/export/export.wav

That said, I have had problems with export not working reliably sometimes too and it has been so rare and intermittent as to be almost impossible to come up with a set of things that make it happen, other than (as other users have said) the export has almost certainly failed if it happens instantly - it should normally take some time. If you cannot export the session, you can bounce it to a new track which means playing it back in realtime and re-recording the output to a new track - which takes longer than exporting, but it should provide you with a working .wav file

Hi, I’m having this issue. Did someone find a fix for it?

Everytime this happens to me, I’ve forgotten to check the left and right channel in the export dialogue. Like Peder said.

Ardour 2.8.16 can’t export a complete file with SRC here. It’s always truncated, by a seemingly random amount. The workaround I’ve been using for the last couple of years is to export at the session sample rate (which works fine) and then use sndfile-resample to convert, then sox to dither down to 16-bit if required. Sox can in theory do both with a single command, but I haven’t had much success with that and haven’t had time to investigate further. The alternative is to use Ardour 3, which (so far) hasn’t suffered from the same problem here.