Exporting ranges

Hi all … I have a weird one. I’ve been exporting ranges (selecting a single song out of a set-long recording) without any issues until recently when for some bizarre reason, one of the tracks decided not to ‘play’ during the export. When I play the song, all tracks play, but when I export, the kick drum track doesn’t go. I can see the small level meters for all the tracks and the level on the kick is basically ‘off’ during export.

The only changes I made before this started happening was to add a couple of busses; one with a reverb plugin to send snare/toms to and the other with a delay plugin for vocals. These are working fine. I also changed the export settings from 16 bit to 24 bit since the previously exported stereo file seemed to be missing a bit of punch in the low end. What does export now sounds much better when listening to it in Audacity or Audacious, much closer to how it sounds when playing the actual mix in Ardour – except that the kick drum is missing.

As I mentioned, I have exported this same range a number of times before adding the busses and switching from 16 to 24 bit on the export settings, with no problems other than the quality not being as good as it should be. Note that I have not switched the export bit-ness back to 16 yet to see if that is the issue. Regardless, exporting at 16-bit isn’t giving me the quality I need so I do want to get this working properly with 24-bit.

Anyone experience something like this before?


Hi, i’ve had problems also exporting some files in A3, that when using 24bit the actual export would be absolute silence… but i didn’t try it much further… however in your case i would consider to swtich back to 16 bit not as a workaround but to corner the bug if it is a bug after all so you can report it, the worst case would be that it is a bug and you coulnt export at 24bit for a while until its fixed, in the best case it would be a circunstantial bug (as it seems to me) and after checking that everything is ok you could start exporting at 24bit again with all tracks fine…

hope that helps.

Hi Fernesto, thanks for the response. I did try going back to 16bit for the export, but I still have the same problem. I then tried every ‘bit-ness’ option with no success. The kick drum, which is on Track1, just will not play during the export.

Now I’m starting to wonder if it has anything to do with my creating busses. I initially created a send on track1 and then deleted it when I decided I didn’t want to add any additional processing to the kick. I wonder if the inputs from track1 at the buss are still there … I just assumed they would vanish when I deleted the send. I’ll have a look and report back…

UPDATE: still no joy. The buss inputs from the kick track did indeed disappear when I deleted the send on the kick track. I thought maybe if the inputs were still there, they might be listening for a send from track1 that no longer existed and maybe that was causing this glitch.

I also tried selecting a range in just the kick track and exporting that, but it still will not play through. I’m totally stumped now.

UPDATE 2 – I still have no idea why this problem is occurring, but I have discovered a workaround.

  • I redid the kick by creating a new track, importing the raw audio and redoing the inserts. Once I had the new kick track sounding like the old one, I muted the old track and tried the export and lo and behold, it worked.
  • I then deleted the original kick track, leaving the new kick track in its place as track 1. Yes, you know what’s coming … my next step was to add some automation to our drummer’s vocal track since he only sang a few lines in the final chorus of the song: fader down through the song then up for his lines and back down again. Sure enough, once I did the automation, when I went to export the song again THE KICK DIDN’T GO.

(insert hair-pulling smiley here)

  • once again I recreated the kick track, only this time I left the now-not-exporting kick track in place as track 1 and put the new kick track as track 2, leaving track 1 muted.

  • I then exported the song, which worked fine as I now expected it would. I then made a few tweaks to the background vocal automation and ran the export again and sure enough, track 1 did not export but TRACK 2 DID!

This proved that the glitch is affecting only track 1, and appears to manifest whenever doing anything other than working with tracks themselves. So, basically my work-around for this problem is to leave a ‘sacrificial track’ in place as track 1 so that this glitch has something to glitch-on without affecting any of the tracks I need.

At least I can work now…

You haven’t mentioned which version of Ardour you’re using. Note that A3 should only be discussed on IRC or as bug reports in the tracker until it reaches beta.
If you’ve got the time please recreate the error and try bypassing the effects to see if that’s the culprit. I’ve had combinatins of swh and tap plugins causing really weird errors.

Also, on an unrelated note , if you’ve got the time, please do an ABX (or at least a blind) test between the 16 and 24-bit export. Most likely you’re fooling yourself into “hearing” that the 24-bit sound better.

Hi peder…

I’m using Ardour 2.6 (can’t recall the exact version #, I’ll follow up when I get home.)

I have done an A/B comparison between the 16 bit and 24 bit export, and the difference is striking. The 16 bit sounds like the bass was rolled off compared to the 24 bit. You can also see it in the waveform when you open both versions up in Audacity; the amplitude of the 16 bit export waveform is much narrower. And when you play them, the 24 bit export sounds significantly louder, which could be due mostly to the apparent loss of low end information. I’m not surprised by this since the original recording was done in 24 bit . Throwing away 1/3 of the information when exporting to 16 bit has to have an impact. (yes, I had initially forgotten to check that the export bit-ness settings were correct when I did the first few exports).

Regardless, as mentioned above I have determined that the glitch with track 1 not exporting has nothing to do with the bit-ness of the export. It manifests whenever I add a buss, or add automation to a track. It even reappeared after simply adjusting one of the ‘nodes’ in the fader automation on a vocal track. What doesn’t seem to bring it on is working with the track itself, such as adding a compressor plugin to the snare track, or some such.

I would strongly reccomend trying again with a somewhat recent version of Ardour. Ardour 2.6 is nearly 3 years old at this point and the amount of bugfixes between that and the current version, is quite staggering. It is quite likely that somewhere in there the problems you are bringing up have already long been addressed.


Hiya seablade…

Yeah, I’ve been thinking that an upgrade might be in the cards. Since I’m currently just using Ardour for fun, mixing recordings of my band for our own enjoyment, I thought I could wait until the stable v3 comes out, then upgrade to that. If this workaround I’ve come up with continues to let me do what I want to do, maybe I will wait. But if I run into any other problems, I think I’ll take your advice and upgrade.

Thanks for all the input, everyone. Much appreciated.