Exporting never finishes on ardour 6.6.0

I’m able to navigate to the export menu normally, select my settings, and click “Export”, but the export never finishes. Ardour isn’t totally hung though, because I can still click “Stop Export” to return to my project.

At one point I was getting the error Ignored format '/usr/share/ardour6/export/MP3 (standard).format': encoder is not available, but I installed harvid and that got rid of the error, but not the hanging.

I’m pretty confident it’s not just an expensive task because I’ve tried with a fresh project with a single 2 second audio file and am still unable to export.

Does anyone have any insights as to why this might be happening or how I might get more info about what’s going wrong (after I fixed that initial error, the error log is clean).

Does this happen only with specific format (example: .mp3)?
i recall similar issue with mp3 export on mixbus, which got updated quickly - and mitigated this issue (if there is connection).
might be useful: MP3 export fails

my apologies - i see now that mentioned mixbus version vas 6.2 and you are referring to 6.6.0.

What audio backend are you using? Jack or ALSA?


I’m not sure if this is still helpful, but this happens with every audio format. And I was getting the mp3 error when trying to export to BWAV, so that error is actually probably unrelated.

1 Like

I was using Pipewire as a Jack server. When I switched to ALSA just now, the export succeeded. Looks like a bug in Pipewire (unsurprising, as I’m pretty sure its sound server is still in alpha). Thanks!

1 Like

Pipewire has not implemented JACK “freewheeling” mode, which Ardour uses for faster-than-realtime export. You can only do realtime export if you are using Pipewire at this time.

I tried using real-time export and it hangs on the last frame of audio when using pipewire. I recommend use ALSA or JACK until Pipewire is production ready

1 Like

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.