Exporting mixed tracks from Ardour = loss of effects and mix

Things are progressing well- thanks to everyone who’s posted replies and helped me along; it’s greatly appreciated.

I’ve gotten a good take of a session (one vocal track, two guitar tracks) and mixed them with the DSP reverb, compressor, and EQ into a decent mix. When I export the file to a WAV file, however, prior to conversion to flac, mp3, and ogg/vorbis, I noticed that the export is flat- no effects or EQ at all. I am missing…what?

Thank you!


kvk, Ardour will integrate your effects in the mix if these effects are running inside Ardour. That is, if they are ladspa or lv2 plugins.
In the case of the linuxDSP effects, they are placed in a jack loop, so you have to first record their output into Ardour. Then mixdown.
Hope this makes sense.


Actually, that should not be the case at all. Ardour’s export system is specifically designed to include the use of other JACK clients as part of the processing system. It seems very slightly more likely that the linuxDSP FX might not handle JACK’s freewheeling mode properly, which is what we use to drive the export process. I wish I had a more solid answer for you.

@Paul, I’ve just tested the export feature using several of my plugins as inserts, and it handles freewheel and export fine on my test system.

@kvk if you have the linuxDSP effects routed between ardours main outputs and the feeds to the soundcard then they will not be included in the mixdown, can you give some more info about how you have things routed. Perhaps there is an alternative configuration that means you won’t have to bounce the output from ardour down to another track.

@Paul and @linuxDSP
I stand happily corrected :slight_smile: .
Didn’t know about this (great) freewheeling feature at all.
Thanks for the info.

sorry for this misleading answer.

@linuxdsp: ah, your perspective makes a lot more sense. thanks for mentioning that and clarifying the freewheeling status (not that its really likely that it would be a problem). sorry for casting any aspersions on your FX units!

Paul: no problem, if there are any bugs in my FX units its always good to know about them so I can fix them…

My apologies for taking so long to get back here- thanks for all the speedy replies!!

My current routing:

Track 1 (Guitar) out -> Guitar Bus In
Track 2 (Guitar) out -> Guitar Bus In
Track 3 (Vocal) out -> Vocal Bus In

Guitar Bus Post-Fader: INSERT -> Reverb In/Out (DSP Stereo Reverb SR:2A)+GREQ2 In/Out +Valve Compressor In/Out
Vocal Bus Post-Fader: INSERT -> Reverb In/Out (DSP Stereo Reverb SR:2A)+GREQ2 In/Out +Valve Compressor In/Out

Guitar Bus Output: Headphone Bus(1/2), Master In (1/2)
Vocal Bus Output: Headphone Bus(1/2), Master In (1/2)

I have all the inserts activated and they work fine when mixing post-recording in Ardour; it’s when I try to export that I encounter problems.

But I absolutely love the DSP software and especially the graphical interfaces!!


Does is work if you record the mix into ardour, rather than using Export?

Eg set up a new stereo track called “Mix”

Connect ardour’s master outs to the inputs of Mix

Disconnect the outputs of Mix

Record arm the Mix track

Record and then play the track from beginning to end

Mute the Master bus

Connect the outputs of Mix directly to your soundcards output channels

Play back the track - you should be listening to the full mix now

If this works, you can right click on the region containing the Mix, choose the first option on the menu which opens another menu, and click Export

Thanks- I did get it to work, but I’m not sure what I might have done differently. I opened the track in Ardour, made sure all the inserts were operational and active, did some new mixing, and then exported into a WAV file. But I did NOT open it in Audacity- I simply burned it to a test CD to assess the mix and other levels, and the effects and EQ were present on both the CD and the WAV file when played using VLC.

Of course, now I have to fix all the problems with the mix itself! O frabjous day!

Thanks for everyone’s advice!