Exported wav too (s)low

Hey all,

I am trying to get back into Linux Audio after a few years of abstinence. I use Debian Stable with the kxstudio repositories, a NI Komplete Audio 6 and Jack. Basic recording and editing works like a charm, but exporting a wav results into a a file that is played too low/too slow (by about one half note). A assume there is something wrong with the sample rate? Could you point me to where I could make the appropriate changes?

Is there audio samples or audio loops in your project? If yes, they have the same sample rate ?

I am not sure about the terminology, but I made some recordings on audio tracks - I guess they are then called “regions” and saved as individual wavs in the Project folder. The problem occurs when I mix down/export the whole project to a single wav.

If the recorded files (I guess they must be wavs as well) or the metadata for individual regions contains a way to tweak the sample rate, that would probably not help, because within ardour they sound completely correct. It is only the exported wav that is lower.

So I wonder how I can affect the sample rate of the export, or whether there is some other export parameter that affects the speed with which the wav is played.

I really use a vanilla installation of all the mentioned components.

Sound like it could be a playback sample rate mismatch issue. If you import your exported wavs back into Ardour, do they still play back at a slower speed and lower pitch?

You are exporting at a sample rate that is not supported by whatever you are using to play back. The sample rate is a part of an export profile, and is fairly clearly visible in the export dialog. You could choose between CD and DVD based profiles to hear the difference, since the former uses 44.1kHz and the latter 48kHz.

One explanation is that your soundcard runs at 44.1kHz and your session is at 48kHz.
During normal operations there a symmetrical error. record/play is equally wrong and the error cancels out.
Only the transport moves a bit slower.

However when exporting the files assumed to be 48kHz are re-sampled to 44.1kHz. But since the files are in fact already 44.1k that changes the pitch. That would also match your description: 48/44.1 is about 1.45 semi-tones.

Thank you, that’s very informative. Sorry I was blind to not see the Samplerate settings. So just that I fully understand: there are basically three separate places where a sample rate is set - in the interface, in the session, and in the metadata of a wav file?

Then I guess I need to find an interface or configuration file to control the hardware, or is there a way to affect that from Ardour/Alsa/Jack?

Apparently my interface can do up to 196kHz. Which sample rate would you recommend?