Export to WAV problem (Sample rate?)

I’m extremely new to Ardour (obviously), but I’ve managed to get a few tracks down. When monitoring, everything sounds fine.

When I try to export to a WAV file, everything appears to be OK. When I try to play the resulting WAV back in another application, it plays 2 or 3x sped up. Sounds like a sample rate problem, right?

Here’s my setup:

RME Hammerfall HDSP9632 (Doing the recording from), RME app is set at 48k
JACK is set to 48k
Ardour reports 48k
Exported WAV file properties shows 48k
Motherboard has an integral sound card, an Intel HDA. The speakers are connected to this card.

Now, I have no idea what sample rate the Intel HDA is set to, or how to change it. Both cards are controlled by ALSA drivers. If I configure JACK to use the Intel card, the default setting is also 48k.

Any ideas?



Hi HyTronix,

and welcome to the forums :slight_smile:

Set the exporting sample rate to 44.1 kHz.
Most other applications expect the .wav file to be in Audio CD format, which is 44.1 kHz and 16 bits.


Thanks Benjamin,

I tried this, but it didn’t change anything. Weird.

Any other ideas?


Hey HyTronix,

yes that is weird…

In which exact application does it happen?
Do you stop jack before playing the wav file back in the app?
Could you try to set the jack sample rate to 44.1kHz (so running everything in 44.1)?

You could enter the irc channel of Ardour - irc.freenode.net, channel #ardour (via apps like XChat or www interface http://www.mibbit.com)
to get real time help. Me and several other guys who have much more and better knowledge than I are hanging around there.


I’ll head on over to the IRC channel tonight. To answer your question, though, I’ve tried setting JACKs rate to 44.1k, and every app that plays the resulting WAV is too fast.

However, as a curiosity, last night, I fired up Jammin, and piped two of the tracks into Jammin’s “Left” inputs, and one into it’s “Right”, and connected Jammin’s outputs to a separate, stereo track in Ardour. The playback on this was OK, so I then exported that track.

Still too fast (playing it in Audacity). Oddly, although I exported it as a 16 bit stereo WAB at 44.1k, Audacity said it was a 32-bit float 44.1k stereo WAV. Hmm. Just out of curiosity, I set Audacity to treat it as a 22k file, and it played normally. (???)