Export Silence

Hello Everyone,

I am having trouble exporting audio in Ardour. Anytime I export a session or a selection I get an exported file filled with data, but it doesn’t play. Audio players don’t recognize the file (I was using wav, so the audio player should play it) or it just plays silence.

I’ve been using ardour for a few weeks and I like it a lot, but it’s not much good if I can’t export anything.

Please help

What version of Ardour?

Did you select the master outs for the left and right channels of the file? What does sndfile-info say about the file when its not recognized by various players?

I am using ardour2.1. I have played with different variations of the outputs and channels on the mixer. I can get my laptop to do it if I send the ardour project over to it. I looked for differences in the set up of the two computers and everything looks the same. I’m puzzled.


I have exactly the same problem! I export and ardour seems to export (the meters move etc) but I get a silent file that appears to be corrupt. Can anyone help?


Same here with ardour 2.7.1-1mdv2009.1

Just save, close, reopen the project and export is ok.

what is your sampling rate for recording and for export?

did you switch on the export tracks? and did you put your exporting timeline right (start-end)?

exporting timeline? How do you do that? Is that available in my old Ardour version as well? Because I just posted a question on the matter of marking the end of a song for exporting purposes (see http://ardour.org/node/2085).

with the range tool (simple press ‘r’) you can mark the desired peace of the timeline which you want to export. than menu->export->export range to audiofile


Hello, I am a ardour n00b, and I have a similar problem.

When I hit play in ardour, I hear the music and the meters move in the master. However, the exported range files just contain silence.

I am assuming that the problem is something to do with Master Output, but I don’t understand how the output that I hear is different from the output that goes into the exported files.

Note that when I made a trivial project with a single stereo audio and master everything worked. Then I routed the source track through two buses to balance the left and right channel. The output of the buses goes into the master.

I am using 2.5

What basic concept am I missing here?


many thanks for your quick and accurate response. Setting the range really made a difference! I was able to export a decent audio file.

to opus: what you need to try is to set your channel outputs to master out, to get all channels on the master, and then do the export… if you dont set this it might be that you hear everything but by exporting it doesnt work…

Thanks Calimerox,

Can you explain what it means to “get all the channels on the master”? Does that mean that all channels are inputs to the master, or something else? What is my problem, and why does this solve it?

Can you explain to me about “Master Out”, “out 1+2” and “Output”. What does it mean to select one of those? Where is the documentation all the modes of input and output?

In particular, if the output of my Master track is set to system:playback, and the master outputs are checked in the export dialog, why do the Master meters move, I hear the sound, but the file contain silence?

Thanks again in advance

And the answer is… the file does not contain silence!

But, when Ardour is running, the Ubuntu standard wave player is silent. As soon as Ardour is shut down, the files play just fine.


Thanks for the help. Apologies for being doh!


P.S. I am still confused by what happens when “Master Out” and “out 1+2” are selected in the Output dialog, if someone can explain.

1 Like

Master Out = ardour master channel output
out 1+2 = the outputs of your soundcard


send all of your tracks to the master, then the output of the master goes to your soundcard.

I was having this problem with Ardour 2.3. After I followed the suggestion above to set my ouputs to master, it now exports a faint beeping sound for the duration of the session. It’s not the click track, it’s a different sound altogether. Any suggestions?



It works now. I’m not sure what was routed wrong, but I just routed out of the audio into the master (Master Out), and out of the master to system playback (out 1+2).

Si seablade,

Ademas deber de hacer lo que han escrito los otros usuarios.

Perdon pero hablo espanol muy muy poco. Yo deseo clarificar un poco. Tu debrias marcas uno casilla de verificación para cada un de las (como se dice “output?”)

English (Para Google Translate)

Sorry i don’t speak much spanish. I wanted to clarify a little. You should only mark one checkbox per output.

Hope that got across in some form;)


Encontre una solucion.
Se que este foro no es en español pero usen google para traducir :smiley: .

Estoy usando Ardour 2.7.1 en Ubuntu 9.04.

El problema era que al exportar habian 2 salidas no seleccionadas (mira la foto):

Free Image Hosting at www.ImageShack.us

Seleccionalas y tambien make lo que escribio pauldeshaw.