Export Problem in 5.5.0

Hi there
Since the last upgrade (Version 5.5.0.) I used Ardour for the first time and everything seemed to work fine until I tried to export the session to a wav file.
The export window grayes out and nothing moves until i abort the export.
The Ardour log says:
[INFO]: Searching for export formats in /home/janez/.config/ardour5/export:/opt/ardour/share/export

A friend of mine doesn’t seen to have the same problem using the same version on the same system (Debian/kxstudio)

Any ideas?

Most likely reason: your system has an old version of JACK that has a bug which was fixed more than 2 years ago. If you were using JACK, you can test this by starting Ardour and using the ALSA backend instead.

Thanks Paul
I tried that and it worked. But now it works with or without jack. I think jack is kept pretty much up to date by kxstudio. (jackd2 version 2.1.9.11)
I drove me crazy last night. I could playback and edit but no way to export. I finally transfered all the data to an old laptop and exported it from there.
Yesterday I also had a nasty phenomenon where the Ardour window got way to big beyond the edge of the Monitor to the bottom side and was not resizable to fit the screen. The faders in the mixer where basically gone.
Today everything seems fine again although yesterday of course I also tried to reboot the machine. I have no idea what happened. The difference between a normal restart and a cold boot? vodoo?
Thanks for the reply

Exact same problem (and log info) here with also same versions of Ardour 5.5.0 and jackd 1.9.11 just like Janez reported.

I could export with the ALSA backend, too, but after that trying to do the same with JACK once again, the export still gets stuck and xruns start counting rapidly.

I’ve had the same issue in the past few days (and managed to export fine with the ALSA back-end). It’s weird how it’s been a problem for a number of people around the same time, but I’m glad I saw this thread though.

Just this morning I had a whole slew of updates (I’m an UbuntuStudio user), including jackd2 (now at version 1.9.11~20161209-1~xenial) and export works again with JACK :slight_smile:

Okay, a few system updates later and exports are working for me again as well. Hooray! :slight_smile:

As I’ve run into a very same issue, I found out that this is related to JACK freewheel driver, which refuses to work in, for example, versions provided by KXStudio repos.

@alexthebassist With 2:1.9.11~20161209-1~kxstudio4 of jackd2 it’s working again for me.

@zelosity: only stock Debian package worked for me.

Hi All, I had today (17/10/2020) exactly the same problem to export audio session with ardour. My workaround was to export the session with alsa instead of jack but I want to know if there is a solution. It was working fine until a month ago. I need to mention that I have installed some OS updates during this month. The versions are the following:

Ardour 5.12.0
Jackd2 2:1.9.12
Ubuntu 18.04
QjackCtl: 0.4.5

thank you in advance!

Don’t use 3 year old jackd version. 1.9.15 was released this past week, use that, or at least 1.9.14 which is only 1 year old.

1 Like

Hi ccaudle! Thanks for your answer! There is a web or git where I can download that version? When I do apt-get install through terminal I get a message saying the version installed is already the last one, thats why I didn’t realize that there are newer versions, thank you in advance !

I don’t use Ubuntu myself, but I believe there are additional repositories you can add which have up to date audio software (maybe Ubuntu Studio, https://ubuntustudio.org/)
Other than adding additional repositories to your existing installation the direct location for jackd software is here:
https://jackaudio.org/downloads/

ubuntu 20.04 LTS has an up to date version of jack. And ubuntu studio keeps a backports PPA with any newer jack versions as they come out. (Ubuntu 20.10 was just released as well) Upgrading the os would give you a newer version of Ardour as well.