Export-Error - unwanted Silence @ Start, unwanted cut-off at End of File

Hi @ all,

i am running Ardour 2.5 .

If i export a Range or Session i get a really bad Problem/Error.

For example, right now i want to export a 16 bars beatloop consisting of loads of samples - i simply want to export that into one new file, and then import that file again so i have a clean and easy to handle 16bar-Loop.

The strange thing:
If i open the exported file it has

  • a short silence in the beginning
  • the end of the loop gets lost/cutted off

How and why does this happen?
It makes it nerve-grinding to produce beats in this way - so what is the proper way to get my loops out of ardour without anything missing?
I simply need 100% precision :wink:

I read about the “consolidate range”-Option in another Thread, but either it doesn’t work on my compile or i don’t get it.

But let’s stay on the main topic:
How to export clean?
Without silence sneaking in at the beginning, and without creepy cut-offs at the end?

Can it have something to do with latency and JACK?
My Jack-Latency is set to 1024. But that shouldn’t do anything on exports?

Please help me out of editing-hell :wink:

I remember a bug a while ago where i got export ranges to work once i set it to “snap to CD frames”. Let us know if that helps/doesn’t help!

Thanks for the Tip, but bruce-unfortunate-lee it didn’t work.

I set the snapping to “Grid” and “CD Frames” and exported the whole session again (Session - Export - Export Session to Audiofile) with the following settings:
Channels: stereo
File Type: WAV
Sample Format: 16 Bit
Sample Rate: 48kHz (Session and JACK is 48kHz too)
Dither Type: None
CD Marker File Type: None

So, nothing special as far as i can see, not much i could possibly do wrong.

Before setting the snapping back to CD Frames i set the Session-Markers to the beginning and end of my Loop with Snapping-Grid-Bars on, so the markers are in the right position, i verified that as i do almost always by zooming in at the beginning and end of the loop.

The strange thing is, the loop is exported with the right overall length, but in the beginning i have a short silence, and so the end gets cut-off and everything isn’t on time anymore.

I mean - does it work with everybody else here?
Positive Feedback needed - if clean export works with you - post it here - so i know that it can work, even if it doesn’t for me here.



Months later.

The Problem prevails.

I got used to work around that issue, but it still sucks.

Nowadays i simply export the whole session plus some silence in the end, reimport the loop and recut the beginning and end - it is simply a stupid step of work. So for me personally i can live with that for now, but it really is too bad, that i can’t export clean loops.

Maybe i’m gonna compile the new version, i’m still on Ardour 2.5… …but on the other hand, i got no time to fix this problem, i guess i’ll simply keep working like this.

Has anybody the same problem? Or can anybody confirm that the exports are working clean in his version 2.5 (maybe i got a strange, unknown error in my self-compiled 2.5?)?



I have the same problem here. When I reimport the loop I just exported in Ardour, I can see that the very end was converted to a silence (compared to the original).

As jonobo wrote, I need to export the loop plus some silence afterwards and then trim the loop in another tool.

I would be happy to donate to see that fixed.

@djib: what version of Ardour are you encountering this problem on? Also: http://ardour.org/how_to_report_a_bug