ESI Juli@ Linux Compatibility?

Hi all,

i am currently thinking about buying a new sound card.
My personal favorite ist the Esi Juli@. That device seems to be cool,
especially the supported sample rates, the variable symmetric/non symmetric
in/outputs and so on.

But there are often reports about problems with the midi ports.
So, is anyone using this card and can tell me a short feedback about it?

I know, its not a direct ardour related problem, but its hard to find information about it. Not many people are using cards like these under linux. Most common answer was: @Linux? Don’t know, but it works fine under Windows and OsX…

Thanks a lot for your help,


About the Juli@… I couple years ago when we tried it in our Linux computer we found that it would freeze the machine if we attempted to connect anything to the MIDI ports (I mean within alsa, eg: using aconnect) and we’d have to do a hard reboot. I found out somewhere that it uses a proprietary driver for the MIDI or something.

Things might have changed since then though, I’m not sure.

Besides that the card worked fine for us.


yesterday i got the card, and tried it out. Alsa works up to 192kHz.

I’m just a bit confused to jack, and i didn’t got it working.

Jack log says the following:

++ jack_rechain_graph():
client alsa_pcm: internal client, execution_order=0.
– jack_rechain_graph()
3364 waiting for signals
01:51:37.629 Server configuration saved to “/home/beowulf/.jackdrc”.
01:51:37.631 Statistics reset.
01:51:37.674 Client activated.
01:51:37.680 JACK connection change.
01:51:37.685 JACK connection graph change.
new client: qjackctl, id = 2 type 2 @ 0xb6334000 fd = 16
++ jack_rechain_graph():
client alsa_pcm: internal client, execution_order=0.
client qjackctl: start_fd=7, execution_order=0.
client qjackctl: wait_fd=13, execution_order=1 (last client).
– jack_rechain_graph()
ALSA: poll time out, polled for 31999125 usecs
DRIVER NT: could not run driver cycle
jack main caught signal 12
starting server engine shutdown
stopping driver
removing disconnected client qjackctl state = Not triggered errors = 0
removing client “qjackctl”
removing client “qjackctl” from the processing chain
cannot read server event (Erfolg)
cannot complete execution of the processing graph

Jack is started by qjackctl and this options:

/usr/bin/jackd -v -t1000 -m -dalsa -r48000 -p1024 -n2 -D -Chw:0 -Phw:0 -s

The Midi ports are killing the Kernel, but that is not as important as the jack problem. Has anyone had something like this before, and solved the issue? That would be a great help…


i just tried to solve that problem by trying out the 2.6.26-rc3 kernel. Lots of bugfixes were brought into this regarding ice1712, ice1724 and the Juli@.

That kernel solved the problem for me.

The Midi problem still exists for me, and i will try to care for it.


Where are the midi ports in this card? I can’t see them.


the midi ports are available through a breakout cable.

You can see it here:

Oh, OK :slight_smile:

Anyway, I’m not using that card so I can’t give you advice: but I’m using a card that provides similar performance - M-Audio DELTA 66 for years (4 inputs, 4 outputs, 2 s/pdif) and it’s working great. I used a Midiman to provide MIDI ports and it works flawlessly.