Error on 100 plugins: "No knowkn data type"

Ardour crashed repeatedly on me on existing sessions after the latest pipewire update (on Archlinux) combined with a replacement interface, while an empty new session worked ok.

While hunting for the root cause, I took an extensive look at the plugin window after a rescan and noticed that I have a lot of errors on LV2 plugins, all (or almost all) caused by a “no known data type.” I’m estimating about a 100 (!) plugins have errors (sorry, I didn’t count them all). I never used any of them, so I’m not sure if this is a new problem. Errors start with “adsr” adsr_gt" and continue all the way down.

I managed to solve my crash issue (i think it was wine/yabridge related), but it is unnerving to see all these errors and I worry they may cause problems in the future. Or, more likely, be the symptom of an underlying problem that may give e grief down the line.

Should I be worried? Or just be happy that Ardour worked again?

This is likely caused by LV2 plugins which have CV (control voltage) ports. Those are only useful in modular synthesizers.

Ardour ignores those plugins.

Thanks for the super-quick reply Robin. I’ll take the be happy option then.


This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.