[ERROR]: Could not understand ardour file... Session fails to load... XML issue...

After working several hours on a piece for a portfolio, several tracks disappeared after undoing several steps. This prompted me to restart ardour through the shortcut Ctrl-Q. When I tried to reopen the file I received the following messages in the log…

[ERROR]: Could not understand ardour file /home/maxwell/texture/texture.ardour [ERROR]: Session "/home/maxwell/texture (snapshot texture)" did not load successfully

I tried again through the terminal and received the following in the terminal:

maxwell@ubuntu:~$ ardour2 WARNING: Your system has a limit for maximum amount of locked memory! This might cause Ardour to run out of memory before your system runs out of memory. You can view the memory limit with 'ulimit -l', and it is normally controlled by /etc/security/limits.conf Ardour/GTK 2.1 (built using 2513 and GCC version 4.1.3 20070929 (prerelease) (Ubuntu 4.1.2-16ubuntu2)) Copyright (C) 1999-2007 Paul Davis Some portions Copyright (C) Steve Harris, Ari Johnson, Brett Viren, Joel Baker Ardour comes with ABSOLUTELY NO WARRANTY not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. This is free software, and you are welcome to redistribute it under certain conditions; see the source for copying conditions. loading default ui configuration file /usr/local/etc/ardour2/ardour2_ui_default.conf loading user ui configuration file /home/maxwell/.ardour2/ardour2_ui.conf Configuration::pack_canvasvars () called, canvas_colors.size() = 82 ardour: [INFO]: Loading ui configuration file /usr/local/etc/ardour2/ardour2_ui_dark.rc theme_init() called from internal clearlooks engine loading system configuration file /usr/local/etc/ardour2/ardour_system.rc loading user configuration file /home/maxwell/.ardour2/ardour.rc ardour: [INFO]: Using SSE optimized routines ardour: [INFO]: looking for control protocols in /home/maxwell/.ardour2/surfaces/:/usr/local/lib/ardour2/surfaces/ ardour: [INFO]: Control surface protocol discovered: "Generic MIDI" ardour: [INFO]: Control surface protocol discovered: "Mackie" powermate: Opening of powermate failed - No such file or directory ardour: [INFO]: Control protocol powermate not usable loading bindings from /home/maxwell/.ardour2/ardour.bindings Loading session /home/maxwell/texture using snapshot texture (1) raptor error - XML parser error: Input is not proper UTF-8, indicate encoding ! Bytes: 0xB6 0x40 0x2D 0x35 raptor error - XML parser error: Opening and ending tag mismatch: Regions line 120 and Region raptor error - XML parser error: Opening and ending tag mismatch: Session line 2 and Regions raptor error - XML parser error: Extra content at the end of the document

I renamed texture.ardour.bak as texture.ardour and tried to open that, but I received the same errors. I know that it must be an error in the XML file, but I am having a hard time figuring it out, here uploaded a link below of the the XML file.


Let’s see… I don’t know what else you need to know… I am running Ubuntu Gutsy, and I compiled ardour from source (2.1)… I am also running Jack 0.107.5, and I am using a Focusrite Saffire LE through Freebob… Ardour has been running pretty smoothly… every once in a while it shuts down, but nothing like this has happened before.



yeah… i noticed those files as well. i have them in my /interchange/…/audiofiles folder too. i think they came from when i previously tried to bounce the “beeps” track. when i attempt to delete them from the xml file, recieve the “programming error: unknown region type passed to Session::add_region()” error upon starting up ardour.

as for memlock… i have it set at 250000. i have commented it out of limits.conf in the past, but i still received the same error upon startup so i uncommented it. do i have to comment it out and recompile ardour for the error to go away?

You’ve got some extremely oddly names for audiofiles present in that session file. Do you have any idea where these might have come from? examples:

 name=" @73850.wav"
 name=" @73850@52540.wav"

ardour is also warning you about a limit on locked memory size that could have some relevance to this problem. what does your /etc/security/limits.conf say about your mlock limit?