Error building aubio 0.3.2


I’d like to build Ardour 2.5, but the new required library, aubio, is a little complicated for me to install.
I use Zenwalk, a Slackware-based distribution, and I didn’t find any .tgz for aubio 0.3.2, so I want to compile it.

The “./configure” step works fine, but when I run “make”, I get the following error :

make1: entrant dans le répertoire « /home/aymeric/InstallLogiciels/MAO/Ardour/aubio-0.3.2/aubio-0.3.2/ext » if /bin/sh ../libtool --mode=compile gcc -DHAVE_CONFIG_H -I. -I. -I../src -I../src -Wall -Wextra -I/usr/local/include -I/usr/include/alsa -g -O2 -MT midi_alsa_seq.lo -MD -MP -MF ".deps/midi_alsa_seq.Tpo" -c -o midi_alsa_seq.lo `test -f 'midi/midi_alsa_seq.c' || echo './'`midi/midi_alsa_seq.c; \ then mv -f ".deps/midi_alsa_seq.Tpo" ".deps/midi_alsa_seq.Plo"; else rm -f ".deps/midi_alsa_seq.Tpo"; exit 1; fi gcc -DHAVE_CONFIG_H -I. -I. -I../src -I../src -Wall -Wextra -I/usr/local/include -I/usr/include/alsa -g -O2 -MT midi_alsa_seq.lo -MD -MP -MF .deps/midi_alsa_seq.Tpo -c midi/midi_alsa_seq.c -fPIC -DPIC -o .libs/midi_alsa_seq.o In file included from /usr/include/bits/errno.h:25, from /usr/include/errno.h:36, from /usr/include/alsa/asoundlib.h:39, from midi/midi_alsa_seq.c:37: /usr/include/linux/errno.h:4:23: error: asm/errno.h: No such file or directory midi/midi_alsa_seq.c: In function 'aubio_alsa_seq_run': midi/midi_alsa_seq.c:345: error: 'EAGAIN' undeclared (first use in this function) midi/midi_alsa_seq.c:345: error: (Each undeclared identifier is reported only once midi/midi_alsa_seq.c:345: error: for each function it appears in.) make1: *** midi_alsa_seq.lo Erreur 1 make1: quittant le répertoire « /home/aymeric/InstallLogiciels/MAO/Ardour/aubio-0.3.2/aubio-0.3.2/ext » make: *** all-recursive Erreur 1

Can you help me, please ?


PS : I’m french, so I apologize if my english is painful to read.

OK, I found a .tgz There.

I should have searched more carefully, sorry.

So your problem is solved?

Not completely.

This error occurs everytime I try to compile with GCC…

But it’s solved for aubio.

Your problem is this: /usr/include/linux/errno.h:4:23: error: asm/errno.h: No such file or directory, i.e. you’re missing asm/errno.h.

I don’t know Zenwalks but in Mandriva this file is included in the glibc-devel package and in openSUSE11 it’s (erroneously I think) in linux-kernel-headers

I asked in the french Zenwalk forum. I effectively had to reinstall the kernel headers, and it worked!

Thanks anyway, you also had the answer.

Problem solved!