Error building ardour with VST


I was trying many times to build Ardour 2.4.1 with VST 2.3 support using scons 0.98.5-1 on Debian Lenny.

I always have this error :

scons: *** [libs/sigc++2/sigc++/signal.os] Error 1 scons: building terminated because of errors.

What did i do wrong? Or is it the version of scons that makes problems?

Thanks for your help.


I had the the same error yesterday, but without VST support. It seems like it has to do with the gcc compiler, so e.g. in Debian testing, Ardour 2.4.1 doesn’t compile anymore.

2 solutions:

  1. Wait on the 2.5 release of Ardour, rumours say that this should be within the next week or so

  2. compile 2.0-ongoing from svn (, it works fine as far as I’ve tested it.


Ok, thanx a lot for your answer Benjamin.

So i’ll wait a bit, and if time seems to be too long i’ll try the second solution.


There were some posts awhile ago about a recent version of scons that was buggy, Perhaps you could try the version of scons from Debian Etch?

I am using scons 0.98.3 with Ubuntu and have compiled Ardour 2.4.1 with VST Support without problems.

Hi GMaq,

I already tried it, i had exactly the same error message.