ERROR: AudioSetup value for samplerate is missing data

I recently upgraded my ubuntu 7.10 system to 8.04 and found that my trusty Ardour 2.05 is not working anymore (I got an Error message, daying that my harddisk ( 250 GB, one year old) is found too slow. OK, we got a problem here.

I checked here on the Ardour site, figured that 2.4.1 is the way to go and got it from (explicit ubuntu Hardy Heron 32bit version).

After installing, when opening, I get the “Welcome” page (New Project, Open Project, Audio Setup) and a secons window behind, saying

ERROR: AudioSetup value for samplerate is missing data

What am I up against? Where did I go wrong? I still have my trusty 2.0.5 on my notebook (under ubuntu 7.10), but I would prefer to get my main system (a lot more powerful) running Ardour, too.

Any help is apreciated.


hmmmm - two days and no response …

I uninstalled 2.4.1 and got me the 2.3.1 that is now in the 8.04 repositories. Same problem, same window popping open, same error message.

When I “ignore” that error, I can simply work on the system without any problem so far. Does anybody know what’s wrong?


hello shovelhead,

have you found answer to your question? I keep receiving the exact same error message every time i start the ardour up.

the release numbers you are all using make no sense at all. there is no version 2.4.1 or 2.05 (mayeb there was a 2.4.1 in 2008 but it is so old as to be absolutely ridiculous)

the current release of ardour 2 is 2.8.16 and there is absolutely no reason for anyone NOT to be using it. please stop wasting your time with ancient versions of this program. we fix bugs for a reason - to make your life better. if you’re not going to bother using the current version, why should we bother?