EQ10Q-2-Beta7 Released!

I would like to share with you that I’ve just published a new version of EQ10Q plugins. In this release all GUI has been improved and a FFT visualization tool has been added. For more information and the source code please visit: eq10q.sourceforge.net

Thank you very much. This is an awesome equalizer.
Here is an article on the new release.

When I updated, Iost the plugin in ardour. It was updated via the kxstudio repo. It’s unfortunate as I am working on a song for a dearly departed friend’s memorial service next Friday. Is there anyone else experiencing this? It says it installed but the plugin manager in Ardour can’t find it and whatever instance of the plugin I was using in a given track has disappeared.

Yes, same issue here. I compiled it from source and the EQs don’t show up anymore in the list of plugins (the compressor f.e. does, this only affects the EQs).

Ardour (latest official package) spits out some error messages about the EQ-plugins. Currently can’t post it, yet. Will do so later…

I’m afraid that I’ve introduced a syntax mistake in the EQ ttl files. There is a missing semicolon. I’ve just published a new package for this version fixing this issue and adding some minor changes, it is called Beta7.1. You can get it from eq10q.sourceforge.net. Please, can you report if the same problem arises again with beta7.1?

Now it no longer compiles here…

Error msgs of the second “make” attempt:

[carsten@six eq10q-2-beta7.1]$ make
[ 1%] Built target lib_filter
[ 3%] Built target bassup
[ 5%] Built target lib_vumeter
[ 7%] Built target compressor
[ 8%] Built target compressor_stereo
[ 10%] Built target eq10qm
[ 12%] Built target eq10qs
[ 14%] Built target eq1qm
[ 16%] Built target eq1qs
[ 17%] Built target eq4qm
[ 19%] Built target eq4qs
[ 21%] Built target eq6qm
[ 23%] Built target eq6qs
[ 25%] Built target gate
[ 26%] Built target gate_stereo
[ 33%] Built target bassupwin
[ 35%] Built target bassup_gui
[ 53%] Built target dynamicwin
[ 55%] Built target compressor_gui
[ 57%] Building CXX object gui/widgets/CMakeFiles/eqwin.dir/eqwindow.cpp.o
/home/carsten/src/eq10q-2-beta7.1/gui/widgets/eqwindow.cpp: In Elementfunktion »void EqMainWindow::sendAtomFftOn(bool)«:
/home/carsten/src/eq10q-2-beta7.1/gui/widgets/eqwindow.cpp:636:122: Fehler: »lv2_atom_forge_object« wurde in diesem Gültigkeitsbereich nicht definiert
make[2]: *** [gui/widgets/CMakeFiles/eqwin.dir/eqwindow.cpp.o] Fehler 1
make[1]: *** [gui/widgets/CMakeFiles/eqwin.dir/all] Fehler 2
make: *** [all] Fehler 2

I think it has to do with missing lv2-stuff, but I installed the lv2-devel-package… (v1.2.0 on Fedora 17)

Translation of the error-msg:
»lv2_atom_forge_object« was not defined in this scope

dbra, yes it is pointing to an issue related with LV2 standard headers. This is because I’ve decided to not provide LV2 headers anymore and use the distro-supplied LV2 headers. I though that doing so will better to maintain LV2 related changes and versions compatibility across build environments. However, given the results I should rethink about it. Let me run some tests, and I will come back with further info. Is there anyone else having the same issue?

dbra, I’ve just reproduced the same issue as yours trying to compile the plugin in a CentOS7 box. The problem is the version of lv2-devel package which in my CentOS box is 1.8 however in my Archlinux laptop is 1.10. Using 1.10 compilation is successful, browsing the code of lv2-devel I’ve realized that you need 1.10 to build eq10q due the usage of new atom communications model. I suggest you to obtain an update lv2-devel package and try again.

I’ll grab the source of a newer LV2 and try again tomorrow. (Hope it does not depend on other newer stuff)

I built the latest lv2-release and installed it. Now eq10q compiles fine and shows up in the plugin-list, but when I try to istantiate an eq, ardour complains that it cannot do so. On the console this message appears:

lv_lib_open(): error: Failed to open library /usr/local/lib64/lv2/sapistaEQv2.lv2/eq4qm.so (/usr/local/lib64/lv2/sapistaEQv2.lv2/eq4qm.so: undefined symbol: lv2_atom_forge_object)

Now it works… The error mentioned above was due to the partial build with the old lv2-package… D’oh… :slight_smile: After cleaning up and rebuilding eq10q, everything works fine.

Nice work, sapista!

BTW: What about the sidechain-inputs for the compressors and the gates? :wink:

I’m glad you’ve figured out the solution.
About the sidechain , yes it is planed in my roadmap. But I cannot tell you a date yet. Anyway, if you have some more concret idea about how exactly sidechain signal should be caught from ardour mixer, I will be happy hearing it.

Hmm, I don’t understand your question. SC3 and Calf SC compressor simply have an additional input for the sidechain signal. Don’t know how it could be done otherwise.

dbra@ I asked you about sidechain signal because I don’t like very much the idea of having extra inputs for the sidechain. I would like to implement an easier to handle approach because I think 3rd input connecting may result a bit confusing. Although, I am not able to figure out a more user-friendly approach. I was asking you, just in case you have some conception of how should it work.

Sorry, I’m not into development currently… Don’t know how this could be solved otherwise.

I think, it would be best to supply additional versions of both the gate and the compressor with sidechain inputs. The only confusing thing about three- or four-channel-sc-plugins is: Was the sc-signal on the first or the last channel? Probably you can display a message in your plugin which states that… :wink:

Excellent plugins! The FFT visualization tool is really great. Thanks o lot!