EQ10Q 2.2 released

We are proud to announce the 2.2 version of EQ10Q plugins. Starting from this release we provide binaries for broad range of Linux platforms. All of those binaries are distributed in a single easy-install package. These binaries were build using carefully selected versions of libraries that allows the same plugin to run on the LV2 hosts provided by your Linux distribution and Ardour versions provided from ardour.org.

As always, check out eq10q.sourceforge.net for more information and download links.

Excellent, thanks for all the hard work, I love these plugins.

@sapista: Thank you for all the hardwork. This works from source on Gentoo.

@sapista: Have to say when compared to some other eq plugins this one seems to use the least dsp. I use these plugins on more than 24 channels and it seems to run efficient.

Thank You!! I really appreciate the binaries.

@dsreyes1014: Thank you for pointing out the dsp efficiency. I’ve expended many many time adjusting the eq10q code to be as efficient as I could. And I have to say that in my mixing sessions I usually run around 50 instances of EQ10Q equalizers plus around 50 instances of CS10Q plus some GT10Q and reverbs, delays and so on… and the dsp of ardour is kept below 60% using a buffer size of 1024.

@sapista: That is pretty good. Keep up the good work. I’m really liking these plugins. After we upgrade at our church I’d love to integrate these for channel dsp at some point.

Still crash on Debian.

@alexthebassist: First of all, I would like to apologize for my late response, I’ve been very busy these days. I can’t reproduce any crash on Debian. Please, can you provide more information about your system? It is important to know which version of Debian you are using, which kernel, ardour’s version and how you installed ardour and eq10q. Please provide more information to reproduce the crash. Is this a random crash? Does the plugin load or just crash at the very beginning of instantiating? Is the issue you are reporting related with https://sourceforge.net/p/eq10q/bugs/15/? Are you “Alexey Polevoy” in eq10q sourceforge page? Please, try to provide an accurate way to reproduce the crash, otherwise it will be very difficult to fix.

Have anyone there had any crash using eq10q 2.2? If so, please let me know as much information as possible about your system and the steps to reproduce the crash.

@sapista: No crashes here.

@sapista: Yes, I am Alexey Polevoy, that’s my real name.

My system is:
Debian Stretch 64 bit, always up to date
Ardour 5.5 from here
Kernel 4.8.0-2-rt-amd64
CPU is Intel Core i5-3230M
6 gigs of RAM
Also I have KXStudio repository enabled
Ardour is installed with official installer
Plugins are installed from your archive using your installer

Plugins crash on manipulating an EQ strip, randomly. I can’t be 100% sure, but it seems that hipass/lowpass filters don’t crash, so I think it happens on changing amplification coefficient. In my case, I always get it when cut out resonances or tweak wide cuts. FFT analysis isn’t involved too — crashes happen both with and without it. CPU consumption is okay, I can add about 40 instances and still have CPU load below 40%. Other plugins (not related to EQ) work like a charm.

Way to reproduce:
Add some instances to any project, start tweaking in peak mode, and after some time Ardour will crash. This can take much time to catch, sometimes I was able to almost finish a mix without problems. This happens with any usable JACK settings and with different versions, so it’s not JACK, too.

@alexthebassist: I’ve been testing the eq for many hours in my ArchLinux box, no crashes here. Also I’ve run a test for one hour using ardour’s automation, still no crash. The test consists in setting some automation curves of eq gain parameters in ardour, then play the automated region in a loop for a while. Keep the eq10q gui open during the test so you’ll see the eq curve being changed automatically. Please, can you setup a test like this using automation? This kind of test will told us if the problem is related with capturing mouse events or not (no mouse events are involved in automation test).

In the past, I had some troubles with some versions of RT kernels, so please can you re-test all with a Debian stock kernel? Keep in mind that a standard kernel will do fine with jack buffers around 1024 samples (I use standard kernel on my laptop).

Also, just to discard some issue in debian testing… can you try it on another Linux? For example, AV linux has almost all you need installed out of the box in a live CD. It will take just a few minutes to install eq10q in a live Linux.

And finally, if you know how to generate a crash backtrace using GDB it will be much useful. I can provide an eq10q binary with debugging flags enabled. I’m asking for your help to track this issue down because the crash is not reproducible on any of my systems.

@sapista: No, I can’t test it with a generic kernel, it doesn’t work with JACK even with 1024 or bigger buffers. I get sudden audio skips (lasting up to several seconds) with it, during which everything JACK-related is unresponsive.

I’ll make an automated test a couple of days later, when holidays finish and I get at least half sober.

I’m not sure if I can test it on other Linux, because my USB ports are dead (issues with controller after a short circuit accident) and I don’t know where to buy recordable CDs/DVDs, they aren’t sold anymore. Maybe there are still some, but it requires some skill and a truckload of time to search for them.

Yeah, I can get a backtrace. Last time I did it, it was so easy that even a retarded monkey could do it.

“I don’t know where to buy recordable CDs/DVDs”

@alexthebassist: I don’t know where you are, but blank CD-R and DVD+R are still readily available from online shops here in the UK. Do you have the equivalent of amazon.com that you can order from?

You can also boot AVLinux from a USB-stick. just dd the image onto it (or read AVL’s manual for details)

@x42: no, I can’t. If you read my comment carefully, you can find out that my USB ports are dead.

@jrigg: I’m in Moscow, and here they still can be found in some computer shops, but there are less and less of those. None left in my district. Yes, we have some Amazon-like shops, and, if nothing helps, I’ll order it there.

@alexthebassist: I think that your issues with regular kernels are very strange. Actually, you can enable realtime with a quite good performance in almost any standard kernel. Just be sure your user is in audio group and your hardware interruptions are setup properly. Have a look at threadirqs kernel parameter and rtirq strips. You can use htop command to check that your audio device priority is configured properly. Sometimes, some graphical adapters/drivers may interfere with audio performance. What graphic card/driver are you using?

PS. Instead of a CD or DVD you can always get a new PCI USB hub for a good price (less than 20 € here in Spain). A think that having a computer with working USB ports is a must-have.
PS. Looking forward to get your back trace or more information about the crash. Happy new year!


@sapista Great work and progress on your plugins!

Just to clarify since the AV Linux DVD was mentioned, AVL is based on Debian Stretch with a custom RT Kernel and the KXStudio repositories included. Since the last AV Linux DVD was released (August 2016) there have been numerous BIG changes in Debian testing and occasional minor problems with the KXStudio repos, since they are fairly static and Debian Testing has been quite turbulent making rapid and sweeping changes. I know at release time that the EQ10Q plugins were confirmed to work, but I can’t guarantee that an installed and dist-upgraded AV Linux would be any better than alexthebassist’s current setup with the very latest EQ10Q versions.

I will say for many USB Audio devices (ie Presonus 1818VSL in my experience) an RT patched kernel is almost a necessity for decent low latency performance, however it is true that most onboard, PCI and FireWire interfaces show less significant latency improvement compared with standard or lowlatency kernels. Lastly I will say that RT kernels are getting more and more temperamental with certain graphics hardware, even on my own development desktop system kernels newer than 4.4 give me a kernel panic so alex you may find and older RT kernel may suit you better than the cutting edge ones in Debian Stretch…

@sapista: well, actually I can’t. My experience with Linux counts for more than 10 years, and I know what am I doing. On my particular system, it’s IMPOSSIBLE to use anything other than RT kernel for realtime audio. That is a fact known from continious attempts on trying other kernels for no less than three years.

I have two chips: Intel Graphics (3rd gen), which is always in use, and NVidia, which I do not use since I don’t care about bullshit like computer games. I have Bumblebee set up, and second chip is always off.

Instead of a CD or DVD you can always get a new PCI USB hub for a good price

If you manage to install it into my laptop and get it functioning, I’m giving you a Nobel prize equivalent right after you tighten the last screw.


you may find and older RT kernel may suit you better than the cutting edge ones in Debian Stretch...

I tried a really big number of kernels, including ancient 3.16 from Jessie, and plugin behavior is all the same. Kernel is not the issue here.

@alexthebassist: About the kernel, OK lets keep the RT. Apologizes for the USB-PCI suggestion, I though you were in a desktop PC. Taking into account that you are in a laptop with dead USB… what audio interface are you using? Firewire? Just curiosity.
So, knowing the situation this will definitively require some testing on your system. Please, try the test I described above. In case that you found out the crash is related with GUI part of EQ10Q, please can you re-test it using your nvidia card with nouveau or nvidia proprietary driver (both are working fine for me). Just to discard some issue related with cairo drawing plus graphic drivers…
Thank you in advance for conducting these tests on your system. I’m really interested on tracking this issue down because it is possible that there is a bug in eq10q code that is only manifesting in a particular combination of library/drivers. However, now I don’t know where to start looking for the mistake, so your feedback is much appreciated.