EQ10Q 2.1 Plugins Released

After some months of work we are proud to announce the 2.1 release of EQ10Q plugins bundle. In this release many things have improved and all known bugs have been fixed. The top addition in this release is a new plugin consisting in a side-chain input compressor with the names CS10QM-SC and CS10QS-SC for the mono and stereo versions respectively. However, it also deserves mention the large improvements made in gate and compressor plugins (GT10QM, GT10QS, CS10QM and CS10QS). Gate plugins now includes a powerful expander featuring “ratio” control and a new attack shaping based on S-curve for a better handling transients with fast attack settings. The compressor has been improved by adding two new controls: “Punch” and “S-Release”. The punch control alters the compression attack shape to retain some of the transients allowing a more punchy sound. The S-Release mode changes the release shape to a more linear gain recuperation. In addition, the gain recuperation in S-Release mode is material-dependent in similar way as opto-compressors do. We believe that such additions in dynamics processors adds a great flexibility that is not usually seen integrated in only one plugin.

Apart of this, some improvements have been made in the DSP code of the equalizer and also in the GUI. You can get the latest release in the “Get it!” section of the EQ10Q website (eq10q.sourceforge.net). You can also read the full list of improvements there.

As ever, your comments about your impressions are much appreciated.Thanks for trusting in EQ10Q.

No GUI appears with v2.1 and gcc5.

I’ve just downloaded and built v2.1 with gcc version 5.4.0 20160609 (Ubuntu 5.4.0-6ubuntu1~16.04.2). The build went cleanly.

From the launch terminal, when I try to launch the gui, I get the following error:
suil error: Unable to open UI library /usr/local/lib/lv2/sapistaEQv2.lv2/gui/eq4qm_gui.so (/usr/local/lib/lv2/sapistaEQv2.lv2/gui/eq4qm_gui.so: undefined symbol: ZN4sigc9slot_baseC1EOS0)

$ Ardour5 --version
bind txt domain [gtk2_ardour5] to /opt/Ardour-5.0.124/share/locale
Ardour5.0.124 (built using 5.0-124-gb339cde and GCC version 5.3.1 20160205)

eq10q v2.0 worked properly.

Any suggestions?


This seams to be a library-binary-compatibility issue between your system libs used to build eq10q and ardour.org provided libs (I’m assuming you are using ardour5 binary downloaded from ardour.org. Is that right?)
You can try to re-compile eq10q-v2.0 again, just to discard some library/compiler mismatch in your system.
If you re-build v2.0 keep a backup of your current binaries, just in case the new ones fail.

Please, let me know if rebuilding v2.0 with your current system state produce different results.

I’ve rebuilt and reinstalled 2.0, and now I have the same issue with 2.0. :frowning:

suil error: Unable to open UI library /usr/local/lib/lv2/sapistaEQv2.lv2/gui/eq4qm_gui.so (/usr/local/lib/lv2/sapistaEQv2.lv2/gui/eq4qm_gui.so: undefined symbol: ZN4sigc9slot_baseC1EOS0)

My Ardour5 binary came from nightly.ardour.org

Your problem is that you’re mixing a host built with gcc4 (or gcc5) with a plugin built with gcc5 (or gcc4).

If you download from nightly.ardour.org, you must choose the right version. EQ10Q is one of the very few C++ plugins that is affected by this issue.

If you download from ardour.org/download then the release contains both versions and picks the correct one at install time.

Yes there are some issues related with gcc/libraries. I’m afraid that the situation is complex, for example I’m on Archlinux which is moving to gcc6 but some libraries are still build using gcc5. I’ve tested eq10q on a gcc4 system (debian8) using an ardour.org binary and worked nice. Now I’m preaparing a system with gcc5 support to test it. Because in my Arch box with mixed versions of gcc it doesn’t works on ardour.org binaries, but it works nice on Ardour4.7 (arch repos).

@paul: It will be very nice to know which platform you used to build ardour binaries, in that case I will provide eq10q binaries ready to run in ardour provided binaries. Thanks for your awesome work.

I’m excited to use these. I’ve been using the compressor in feedback mode a lot lately and I’m really liking it. Congrats on the new release!

I downloaded the gcc5 version from nightly:

$ Ardour5 --version
bind txt domain [gtk2_ardour5] to /opt/Ardour-5.0.124/share/locale
Ardour5.0.124 (built using 5.0-124-gb339cde and GCC version 5.3.1 20160205)

and my gcc is also version 5:
$ gcc --version
gcc (Ubuntu 5.4.0-6ubuntu1~16.04.2) 5.4.0 20160609

sapista: Good work! Looking forward to using this in our environment.

Just doing some investigation about scherbi’s issue. @paul: It seams that is not a gcc version problem, i suggest that it is related with two libs versions:
libglibmm-2.4.so.1 and libsigc-2.0.so.0. I reproduced a similar issue on Archlinux using ardour gcc5 build from ardour.org. I fixed it the very dirty-way… just removed (well actually renamed) this two libraries from ardour’s lib path. Doing that eq10q uses these libraries from system (versions 2.48.1 and 2.8.0 respectively in Arch). Such dirty-fix worked for me, but I won’t trust that for a production installation.

My hypothesis is that the gtkmm and sigc++ used to build eq10q is newer than the version used to build Ardour. Please, Paul can you provide the version numbers of libs used to build ardour?

Full build stack details are available for every build via https://nightly.ardour.org/list.php (click on the “Host Info” link for the relevant build).

Great! I see now, it seams that your build system is a kind of outdated debian with gcc5 support, where do you get that?
According to the provided info:
libsigc+±2.2.10 (is market as oldstable in debian’s site)
glibmm-2.42.0 (many distros provides 2.48, could be an issue)

I thinks that this scenario makes difficult the binary compatibility of ardour.org builds and plugins compiled in newer systems. I was thinking to distribute some eq10q binaries compatible with ardour.org builds, but with this lib platform it is quite difficult to me to arrange everything to link to this versions. Please, do you have any guide of how we can enhance plugins compatibility with ardour.org build?

We don’t use any current distro as our base platform. The build systems are specially built to contain almost nothing directly from a distro. We need to build binary bundles that have as few dependencies as possible, which is not generally the goal for most distro library packagers.

So we start with an absolutely minimal base system (gcc, X Window) and then build everything else ourselves.

We might upgrade sigc++ one day, but at present it’s C++11 compliance puts it at odds with the gcc5 versions on many distros.

So I just built Ardour5 from source(git from github), and rebuilt eq10q.
It works, but I’m only getting the generic controls for all of my plugins now.
I figure I missed some dependency or option. Will investigate more later today.

I ran in to the same thing, Ardour5 would build and run but without the LV2 GUI’s. In my case it was not having the SUIL development package installed.

That was it, Robert, thanks! All my plugin gui’s appear to be working now, including those from eq10q v2.1

Were there any reports of ardour crashing with the previous version of these plugins? I’m trying to investigate my I had a very unstable project recently and these plugins are one of the candidates.