End Marker problems


I have imported a cassette tape recording by adding a new stereo channel, and it does record properly. However, I’ve run into an interesting problem. The End marker is set to a little over 5 minutes.
Recording simply stops there even though there is much more to record.

I’ve tried to adjust the End marker beyond the five minute mark, but have been unable to do so.

Is there any way of having the End marker float until the recording is finished or disable the End marker?

Strange, this problem has not surfaced when recording with a mic, or importing existing audio. Is this normal? I can’t find anything on this in the Floss Ardour manual.

I’m using Ardour 2.7.1 with Mandriva Linux, M-Audio 1010LT, and JACK as controlling the input.

I’d really appreciate some quick help with this - I’ve got a huge mess of tapes and then CDs to get done.


There really isn’t anything that can be done unless you show that this is still an issue in 2.8.11. This could be a bug that is quite difficult to trigger and may well be fixed in later versions. There have been many hundreds of fixes between the 2.7 version you are using and the 2.8 version that is current. What you describe does not conform to what should be happening, it wasn’t designed that way, it should be functioning exactly as you want it to.

I’d say it’s impossible for Ardour to differentiate between a signal coming from a mic or a cassette deck; it only sees a jack input stream.
So the only thing that could affect it, and trigger a bug, is perhaps if the mic signal goes to a mono track and the tape to a stereo.

You could try opening Window/Locations (Alt+L) and see if you can edit the End value to something fitting.

Thanks for the reply.

The stereo tape inputs from the cassette deck (Audio 1) are set as ‘Normal’ not ‘Tape’ in my Ardour session.

I’m going to try to find out why the mic input doesn’t exhibit the same weird behaviour, and see if I can duplicate it with a mic input. Perhaps then I will discover what’s happening.

I’d like to use Ardour for digitizing these analog tapes, and I’m willing to put up with the inconvenience of being unable to monitor the recording. Still . . . .

This big project will be put on hold until I’m satisfied I cannot alter this behaviour.

Any ideas or suggestions are more than welcome.

The tape tracks are one of the few things in Ardour that are destructive, and typically should be used for specialized purposes. If you are tracking, 90-95% of the time you should be using a regular track, not a tape track.

The tape track was originally put in after sponsorship from Harrison consoles for post-production audio if memory serves, where you could bounce things in realtime, and only bounce one small portion you made changes to in realtime and destructively, so you aren’t bouncing out the entire film every time. This is going off memory and I could be wrong, but the point is it is a specialized purpose tool that in most cases probably isn’t the correct one.


Perhaps I should have clarified what I meant by ‘can’t I adjust the End marker beyond the five-minute mark’.

After I have finished a recording, the End marker does, in fact, reposition itself. However, during recording, the visible waveforms are frozen at the five-minute mark. Thus, I have no visual feedback of the recording after that time mark.

I suppose what I’m really asking (even though I settle for what I have now) - is there any way of unfreezing that End marker before I start recording?

Why is it doing this with a tape input, and not with a mic input? With a mic input, the End marker has no effect on the recording - it shifts until the recording is finished - it just isn’t an issue until recording is finished.

I’m really puzzled by this very selective behaviour.

You should be able to move the end marker, the fact that you can’t is not right. I don’t remember there being a bug related to that so I can only think that it is a setting somewhere. Do you have the grid/snapping enabled ? Right click on the end mark and check the properties there, maybe it is locked. You should just be able to record past the end marker and it will reposition itself to the end of the newly created audio.

Thanks for the quick reply.

As far as it being an old version, I’m quite aware of that. However, the latest 64-bit version of Mandriva Linux does not ‘discover’ my printers, so I need to use an older version, until that bug is fixed.

I’ve tried compiling the latest version of Ardour, but I have run into conflicts with Scone, so that’s not an option.

My laptop has the latest version, but it does not have a decent sound card, so I would get zillions of xruns. Thus, I’m left with 2.7.1 on my main box until the OS upgrades to a newer version of Ardour (oh, this is very sad, but that’s the way things go).

Your suggestion works. However, I’m still left with the question: why can’t I adjust the End marker beyond the five minute mark - is this normal? Now, if i could upgrade to the latest version of Ardour, would I still run into this problem? Is this a bug, or is this just the way things work in Ardour?

I would like the option of moving the End marker, or still have the transport visible beyond the End marker (which does not happen if i uncheck, as per your suggestion.)

Any ideas on this?


That’s what I thought, but it was worth a question to see if I had missed something obvious.

Thanks for your help!

That is quite an old version of Ardour, 2.8.11 is latest. That being said though, there is an option in the options->misc options menu that stops the transport at session end. Try un-ticking that.