EnablePlugins.lua is not present


(woojtek1) #1

Hi everyone. I have been using Ardor for years. From the first version. I registered, however, until today. I greet everyone. And immediately I have a question about the Lua script. In my version of Ardor (5.12.0) Ubuntu Studio 18.04 Lts, I can not find the EnablePlugins script. Bypassplugins is, and the enable plugins are not. I tried to add myself. Unfortunately to no avail. Once again, I greet the community. :slight_smile:


(Robin Gareus) #2

There is no such script to un-bypass all plugins that comes with Ardour.

I suppose you can copy+edit the existing script (linked below), change the name and copy it to you local script folder; on Linux: ~/.config/ardour5/scripts/ the filename there needs to end with .lua.

In 5.12 PluginInsert activate() instead of deactivate() will do the trick.

compare to


(woojtek1) #3

Thanks. But I thought it was? https://github.com/rghvdberg/OSC97/tree/master/scripts


(Robin Gareus) #4

That’s part of some user repo.
It looks like Mr van den Berg already did the work and copy/edited the script (but kept the original author).

In Ardour5.x, editor/GUI scripts are also per session, while in Ardour 6 they’ll be in a user’s config, hence he apparently included those for convenience in his git repo.

Anyway, the instructions in the https://github.com/rghvdberg/OSC97/tree/master/scripts#readme are good.


(woojtek1) #5

Thanks. But I don’t know, where paste scripts. In Ubuntu, I don’t have scripts catalog in my home catalog. I should create it?


(Robin Gareus) #6

yes, create that folder, or from a commandline:

mkdir -p ~/.config/ardour5/scripts
cd ~/.config/ardour5/scripts
wget https://raw.githubusercontent.com/rghvdberg/OSC97/master/scripts/EnablePlugins.lua

(woojtek1) #7

Tahnks a lot. I don,t know. I did everything the same, but the plug did not appear. Now, everything works now. Thanks a lot :slight_smile: