Editor scrolling/zooming gets progressively slower

I have this issue where scrolling/zooming in the editor becomes really slow after i start moving regions around. I’m not recording any new audio at all, just moving, splitting, resizing. If i save and restart ardour, it’s instantly fast again. Any idea what’s going on?

I’ve tried changing undo levels down to 5, but it does not make a difference. Ardour 2.8.3 and 2.8.6 on Ubuntu 9.10, 32 and 64bit.

I had a similar issue some time ago:


In my case this was caused by LV2 plugin Invada meters, it really made ardour slow as hell…, and was only using one instance on the master track.

Disabling it fixed my problem, try disabling some plugins first and test, if you find out which one it is, if this is caused by a plugin, might as well contact the plugin dev also.

I too have this issue and exactly the same symptoms using Ubuntu Karmic 64 bit and 2.8.2. I frequently end up with lots of regions, because I’m producing experimental stuff with lots of clips. In my professional work I provide medleys and street dance mixes for dance schools, so I always import files and cut and splice them together.


looks like it’s related to my bug report:

Ardour is not that good in handling lots of regions. Decreasing the undo history improves it a bit, but doesn’t solve the problem.
Paul has confirmed this kind of problem in an IRC chat, but it doesn’t seem like it’s high priority, so I started to sponsor it.


The weird thing is that it speeds up again if I shut down ardour, and start it up again. There’s still the same number of regions (or more), but the editor is fast again.

For what its worth I’m experiencing the exact same issue. And yes, the problem goes away after restarting Ardour. I’m using 2.8.1 on 64 bit 64 studio 2.1.

is this issue solved yet? I’m experiencing the exact same problem in ardour2 aswell as ardour3. Just zooming and dragging around, having only one track, no plugins or whatsoever makes the gui really slow and unresponsive after a short time. When dragging the timeline bar it then sometimes also feels like after releasing the mouse button it would stick for half a sec longer and it keeps on dragging too long. I’m using ardour for quite some time now and i’ve noticed this issue for over a year now. I’m running on a core 2 quad with a GF8800GTS and nvidia-drivers on gentoo amd64, so i guess the hardware really shouldn’t be the problem

@mikkl: yours, like the other posts here, doesn’t offer even remotely enough information to begin to diagnose the problem. Please see http://ardour.org/how_to_report_a_bug Since I’d like to diagnose and fix it (although I believe that issue in ardour 2.X is entirely different to whatever is happening in ardour 3.X), your help would be appreciated.

ok, thanks, i’ll have a deeper look into the problem and on how to report a bug and then report it :slight_smile:

Is there any way to get a snapshot of debug info in Ardour, so we can compare a fresh startup, and when in gets bogged down? Is there any info you’re looking for in particular?

So, i’ve made a bug report with the id 3390 (somehow i can’t post links in here?) and while playing around a bit with the issue i found out that in my case disabling measures prevents the slowdown but does not undo it.

@mikkl: I can’t reproduce it here but your insight about disabling measures is very useful. I’ve attached a patch to that bug report; perhaps you could try it out?