Edit is grayed-out on a-fluidsynth and ZynAddSubFX

I seem to be unable to configure any plugins properly, as only “Edit with generic controls” is enabled. In case it is relevant, this is using the default package on Gentoo Linux. I have used both ZynAddSubFX from the package monitor and from Git and get the same result in Ardour5.

For anyone finding this online, I have asked a similar question at https://github.com/zynaddsubfx/user-manual/issues/18.

Do other plugins show their custom GUI, or is this just zyn-fusion?

Is this Ardour from ardour.org/download or a distro build? in case of the latter, check Menu > Help > About > Config. is LV2 UI embedding: True ?

This is a distro build on Gentoo Linux. Neither a-Fluidsynth nor ZynAddSubFX show a GUI. It should be noted that I have no indication that I have the Fusion variety of ZynAddSubFX.

Thank you very much :smiley:

I have just tested some more plugins, and it appears that Helm actually does have a GUI.

That does not have a custom GUI.

Did you try Helm as LV2 or VST?

Some LV2 plugins with custom GUI: zam-plugins, or LSP, and x42-plugins. They’re all likely also packaged for gentoo.

PS. perhaps try the binary/demo: http://zynaddsubfx.sourceforge.net/zyn-fusion.html to rule out a gentoo packaing error of the plugin.

I’m getting a bit confused on what, exactly, Zyn-Fusion actually is… I think I am using ZynAddSubFX and not Zyn Fusion?

ZynAddSubFX version 3.x is called Zyn-Fusion.

It is the first version that has official support to be used as plugin with a proper plugin UI.

Older versions (ZynAddSubFX v2.x) were never realtime safe, nor worked properly as plugins (although some guys provided hacks to do so with varying rate of success).