Edirol FA-66 or Presonus Firebox


I’ve almost decided - I am going to buy a firewire interface: Edirol FA-66 or Presonus Firebox.
I’ve been reading lots of info and forums about those units for several days, and found out many people run them successfully under Linux/Ardour/Jack, and some of them don’t have such luck. So I’m confused a little :slight_smile:

Can you help me make the right choice?
Please describe your experience with these devices. Do all connections (inputs/outputs/MIDI) work under Linux (freebob drivers), no installation/setup/latency problems?

I use Debian x64 (unstable) on AMD X2 x64, 4 GB RAM.
Thanks in advance!

I cannot give you good or bad advice about the Presonus but I’ll share my experience with the FA-66.

In my case, it took a lot of work to make it work under 64Studio 2.0. At first, Jack was quitting randomly and the computer was sometime just freezing. As soon as I compiled my own kernel, everything was… almost… ok. Ant this is with the stock 64Studio Freebob drivers.

Then, ZynnAddSubfx was full of crackles (whatever the size of the buffers) with Jackd so I changed for Jackdmp. Then, stable performance at 3 buffers of 64 (in fact, better than my old Mia at 2 buffers of 64).

But wait… Where’s my midi ports? That’s the only (but big) drawback I have: with Jackdmp, the FA-66 midi ports aren’t showing at all (maybe it’s supposed to be like this!)Gladly, I have my old Midisport 2x2 for midi I/O but I would love to be able to use only the FA-66.

As for the new FFADO drivers, here I have my midi ports but the FA-66 at low latency is unusable (tried also with UbuntuStudio and it was the same). The best I can achieve is 3 buffers of 128, approximately 8ms…

To resume, with Freebob, 64Studio 2.0, a self-compiled low latency kernel and Jackdmp, the FA-66 is useable for me at least. All the I/O’s are available BTW.

In complete contrast, I’m using an FA-66 on a 32 bit dual-processor system and it’s rock solid stable at 2.7ms latency with freebob (this is using Mandriva 2008). All the IOs work, MIDI works, it was truly plug and play. I think Patrice’s issues might have more to do with using a 64 bit system than with the FA-66.

Well, a day ago I had a cheap (in comparison to stock prices) opportunity to buy almost new (with a warranty) Edirol FA-66, so I decided to take the one. I hope it was a good decision. I’ll have it next week, and describe how it goes later.

I must say that Patrice scared me quite much, but DrG restored my hope again :slight_smile:

I use an x64 Debian unstable distribution so in case this is a problem I’ll make a test with a chroot 32-bit environment. I won’t give up without a fight :slight_smile:

Any way I’ll describe my experiences with Edirol in one or two weeks to let you know how it goes, and maybe it will help some other people standing before a choice which interface to take.

Although the choice was done, any comments are still welcome!

I have an FA-66 as well, I use it with freebob on a Centrino (single core) laptop running ubuntu (gutsy/hardy). When I use jackd in realtime mode, it crashes easily. The only configuration I have found that gives reasonable stability is with 2048 buffer/2 periods (that is, high latency), switching off cpu frequency scaling, and disabling the network. That last thing maybe due to an IRQ sharing problem between devices. Midi ports work.

I would be interested in learning some more of your configuration DrG, even if the issues I’m having maybe due to my hardware. Could you tell me which versions of freebob/kernel/jackd are you using, and which jackd options?

Thanks a lot!


My configuration is:
Jackd 0.107.2
Freebob 1.0.3

jackd command line is:
jackd -R -P70 -dfreebob -dhw:0 -r48000 -p128 -n2 -D

Obviously the sample rate switch on the FA-66 is set to 48KHz. I’m using a PCI firewire card which is not sharing an interrupt with anything. This is important. Also I think I switched off CPU frequency scaling - this is really a good idea since you don’t really want the CPU speed bouncing around while you’re trying to do things in realtime mode.

Ahh Debian… :slight_smile: Yes, that new and experimental Firewire driver is, well, new and experimental. I remember a while ago Fedora 7 came out with that driver instead of the old one, and all the users were up in arms about it because basically it doesn’t work (yet). I don’t know what’s wrong with the old one, to be honest. And yes, Debian insist on setting the timer frequency to 250Hz, I guess because they’re thinking more about servers than desktops. You need 1000Hz for any kind of audio work, in my experience (in fact Rosegarden will complain bitterly if your timer frequency is set lower than that). I 'm not sure if it’s the cause of the problem you were getting, but it’s definitely a good idea to use 1000Hz in any case.


I’m using the 32 bit version of 64Studio and Pieter Palmers (the developper of Freebob/FFADO) confirmed that the fact that no midi ports are showing is due to the way Jackdmp (jack for multi-processor) is built.

I switched to jackdmp for crackles and pops only in ZynnAddSubfx. Add to this that I have a Q6600 and that jackd is not mp aware…

How strange. Isn’t it odd the way different systems behave so differently? I tried jackdmp on my system and got crackles and pops everywhere, and I’m not even using ZynnAddSubfx. A well, if it works for you… :slight_smile:

Isn’t it odd the way different systems

Yes, there’s only ZynAddSubFx crackling with Jackd. Everything else works ok (jackd 0.103).

In short my experience with Edirol FA-66 could be described as (almost) plug & play :slight_smile:

This “almost” is because of several issues:

  1. I had to recompile the kernel because of lack of raw1394 module :confused: Yep, the stock Debian (unstable) kernel has only a new experimental firewire driver, which is not supported by freebob/jack

  2. I had recompiled the kernel with realtime patch of the same version, and after that it happened several times that my system hung around starting X throwing on the console the following 6 messages ‘INIT: Id “1” respawning too fast; disabled for 5 minutes’ (with Id from “1” to “6”). Those hangs were once per 5 or 10 boot ups, hard to say. Yesterday I reset the Timer frequency from 250 Hz to 1000 Hz, and recompiled the kernel. I don’t know if it helped or not, because I haven’t had many boot ups since yesterday.

If anyone of you had such a problem, please let me know what it is related to, and how to fix it.

Besides those OS-related issues, I’ve had no problems with the audio unit itself so far. I started jack in the Realtime mode with freebob drivers (in a way similar to DrG’s).
Everything seems to be fine! :slight_smile: Now I have to make some ‘real’ recoding sessions to test it much more (and MIDI too, 'cause I’ve had no possibility to check it yet). But the first impression is really GREAT! :slight_smile:

Thanks for all your help!

I agree - I don’t understand the idea of putting a new driver into a distribution while it’s not working. I know I use unstable but any way… I doubt any application will work with this driver at all.

Setting Hz to 1000 has solved the problem - at least I haven’t had any problems since then.

But I had some problems with Rosegarden. When starting jack with -p128 it caused to have got some underruns and crashed jack after a minute or two (next I had to have reloaded firewire modules to run jack again). With -p256 the situation looked a little bit better - had some underruns, but jack worked more stable (but can’t confirm if it was stable for all the time - not too much testing).

When I use Muse I have no problems and it seems to be stable (with -p128 when starting jack). So now I am learning to use Muse instead of Rosegarden.

But maybe you have such experience or know what to do with this instability problem in case of Rosegarden?

No I’m afraid I don’t need MIDI capability in my sequencer, so I looked briefly at Rosegarden but I don’t use it. Ardour handles everything I need and more.

I have the edirol Fa-66 working stable on my lap.

I bought it last week and after installing a fresh ubuntu studio, it was almost plug and play to. : )

Jack is stable using freebob with 4ms latency — sample rate is 48kHz /// 64 frames/period /// 3 periods buffer

My laptop is an HP Pavillion 6700 running ubuntu studio 8.04 with kernel 2.6.24-19-rt
The firewire chipset is: Ricoh Co Ltd R5C832 IEEE 1394 Controller

The only thing I had to do was:

modprobe raw1394

and then change it’s permission on /dev/raw1394

I tried the firebox some months ago. It recorded, but the gain knobs were not working…