Duplicating track & inverting one does not null out both?

Hi everyone!

I was just about to try out this technique on some drums I recorded recently.
tl;dr: The snare mic has too much bleed e.g. from the HiHat? Duplicate the track, inverse the phase on one of the two. These tracks now completely cancel each other out, resulting in bare silence. Now bring in a compressor on one of the tracks, tweak it until you’re happy. This will eliminate ~90% of all bleed.

But: Duplicating the track and inversing one just does not null the two out on my installation of Ardour. Instead, I got phase shift. Therefore I conclude that there is some latency issue here. Can anybody confirm this?
Copying or sharing the playlist both yield the same result btw., thanks!

Just to make sure: do both tracks have the same volume (with the fader)? Same plugins with the same settings?

Yep, and both are simple mono tracks aligned to center.

Well, I just tried and it worked for me. At first I was surprised that they were not cancelling, then I noticed the faders.

I also made sure to copy by Ctrl + MIDDLE button dragging, to make sure there was not shift. But I got complete silence…

Here we are, both tracks are perfectly aligned (I used the dupilcate function, so I didn’t have to bother with alignment at all), set to -0.6 dB, dead center, no effects, going straight into the Master bus. Yet still only phase issues.

Doesn’t even work when I start up a totally fresh project and import only the one track.
My Ardour is version 6.0.0, maybe this is just a bug?

Did a quick investigation.

If you are using the ALSA audio/MIDI backend, there is no problem.

If you are using the JACK audio/MIDI backend, there appears to be a new-ish bug related to not notifying JACK about a change. Until that happens, you are right that the invert/null test fails. Running jack_lsp -l in a terminal window fixes that (it effectively causes JACK to notice the change).

We might do a hot-fix release to fix this, once I find the actual origin of the bug.

1 Like

I confirm that! I’m indeed using the JACK backend, and the workaround fixes the problem.

Thanks for the help and that after all a rather frustrating day for me ends with having revealed a so far undetected bug \o/

Should be fixed in Ardour 6.2-10-gb5e479dfc3

Please test, https://tracker.ardour.org/view.php?id=8304