DrumGizmo Latency

I am having a problem that I have never had before: DrumGizmo is triggering the samples late, which I assume is a problem with latency compensation… I am not sure how to fix it. I am running the session at 48kHz (no resampling needed in DrumGizmo), and have 32GB of memory (and only about half of it being used). The DSP hovers over 75% and 80%.

I see that I can manually adjust the latency in the plugin (using the “clock” icon on the top left). The value was at 153.0ms, while the session is at 85.3ms. But even adjusting the latency down to 0 samples/ms, it still comes late.

More details: I am using the official Ardour 8.4 (waiting for 8.6 to upgrade). This is an old sessions that I am redoing, so I had all the drum tracks printed. When I went to edit the original MIDI track, I noticed the problem. I in fact have six instances of DrumGizmo running on MIDI buses, but they load custom smaller kits. (The idea is to have control over the room mics for each instrument/group.) But I always do that and never had an issue.

Any suggestions?

1 Like

I notice this, too,

Someone else already a while ago Dumgizmo delay after update to 7.5

Also reported here: Drumgizmo humanizer causes delay - LinuxMusicians

Latency compensation seems to be at failure.
Not sure if it is a problem of Ardour, Drumgizmo, or both in cooperation

Disabling the Timing Humanizer kind of “fixes” it.

1 Like

Thanks, @peter.zenk! I will give it a try tomorrow. Not an ideal solution, but I can manually “humanize” it, at least.

I have also noticed it. I disable both timing and velocity humanisers, then I can reactivate them (or maybe just the velocity one, can’t remember) without the extra latency.