Drumgizmo Failing to load

Hello all.

I have decided to give Drumgizmo a shot and have compiled it from the tarball provided on the Drumgizmo website. Having done so (seemingly successfully) I now face a failure to load in Ardour 3.5.403. I create a midi track, choose the instrument (drumgizmo appears in the drop down list) but when the track creates I get the following error

[ERROR]: LV2: Failed to instantiate plugin http://drumgizmo.org/lv2

So I had me a wee google and this usually seems to be due to an issue with incorrect lv2 install directory. Wasnt sure if this would be the issue as ardour was seeing it to populate the drop down instrument menu - but I thought I would try and dot the I’s etc.

By default it had wound up in /usr/local/lib. So I redid the compile/make/install with the directory specified as usr/local/lib/lv2. Now I have a folder in said directory called drumgizmo.lv2. Anyway - still no dice - the same error.

So I am wondering if anyone has any suggestions on what to do next?


Do you use Fedora? Maybe it is an issue with lib vs. lib64 directory?

Hello dbra.

Thanks for the response.

I actually just managed to get it working. Wiped all of the previous attempts out (a bit of rm action on each folder) then reinstalled again. This time it nagged me about not having lv2 installed (dint do that on the first 2 attempts at./configure). Anyway, the end result is that it now loads into the track. All I have t do now is figure out how to use it. I have never done midi in ardour (or anywhere other than Hydrogen) so it’s time to break out the manual!!

Not sure if it will be workable for me. My workflow involves writing drum parts on my laptop (using hydrogen) then copying across to my desktop when it’s time to record. At first glance it seems like this wont be possible with drumgizmo. But the kits sound so awesome! Will have to try and find a way around it.