drum replacement ladspa plugins?

That’s a relief. Thanks for that, toersi… I was close to correcting myself for assuming too much about carter’s toolchain, maybe I still should.

At any rate, I was able to install this plugin and it went without a hitch-- loaded right up in jack-rack. carter, I’m pretty sure that error means it failed linking to glibc, and it’ll probably be related to Debian’s ways… so now I’m out of my league-- if not already :wink:

i got it working. i love it. thanks toersi. and again for you and ilostmyfiles helping to install.

  1. is there any way you could make the treshold and the hold time more independent of each other? somtimes while recording kick drums i have a problem where the double bass is fast and soft and the plugin doesnt want to pick it up. and when it goes back to slow and harder hits it seems to work fine. the opposite is true when i apply the the settings for fast and soft hits, the hard hits dont come through right.

  2. this may be more work than it is actually worth, but would there be any way to edit/add or subtract more samples within the plugin itsself without having to install it again? i dont know if this is even possible because i have not tried to replace any of the samples i have uploaded anyways.

Ah, sweet.

Way to go there… and you’re welcome. I see (hear) now what it does… nice one, toersi.

Thanks! I wrote it a couple of months ago and was surpried how simple it is. But I think I have to do further development on it. If there are any suggestions how to improve it, let me hear!

Woohoo. This is an awesome plugin and it has dymanics!!! :open_mouth: I am free of windoze replacer plugins. All I ask is support for more samples.

Thanks for the plugin!

I got the time to do some updating and fixing on the trigger-plugin. There was a little bug in the hold-time calculation. Additionally I updated the trigger-engine. I tried to find a good solution for the fast and soft double bass problem, but I couldn’t find any. Edit/add or subtract samples will be a good improvement. But LADSPA don’t have an interface for file selection. The only possible way I know at the time, will be a config-file in which the paths for the file will be stored.

For testing the new version - download it from SourceForge: http://sourceforge.net/projects/ladspa-trigger/

hey guys. i recently downloaded the 2nd version of this plugin and am having some trouble getting it to work. i have successfully compiled and installed it, however when i go into ardour and hit the update button where the plugin list is it gives me this error message

[ERROR]: LADSPA: cannot load module “/usr/lib/ladspa/trigger.so” (/usr/lib/ladspa/trigger.so: undefined symbol: stat)

can anyone help me out?

I don’t know why the stat() function is not available on all systems. But I just released a new version without this function. So try the beta3 on the sourceforge side (shown above). I hope this will do for you.

Btw. I’m working on a new version where you can manage the loaded samples. Maybe this will available soon.

Hi! I tried the plugin, it compiled and worked perfectly. (I had to manually create the /usr/share/ladspa/samples directory, you may wish to add this step to make install).

The “mode” switch is not immediately obvious to me though. I can see in the source that you call them like this:

  1. Normal mode
  2. Additional mode
  3. Switch mode

To me this implies that in mode 1, only the sample is played, in 2, the original sound and the sample are summed (both are played together) and in 3, the sample either overrides the original sound while it is played, while normal sound is played at other times. Do I get the right idea?

I have one problem as well. There is a noticeable and very annoying click (clip sound) at the end of each sample played (well, kick and snare anyway, not sure about the toms). I have no idea why this occurs, as the samples seem to start and finish on or close to zero and the click even occurs in “normal mode” where nothing else could be introducing any DC offset that could cause this. I tried to edit the samples with Audacity and fade out the end of each sample but it didn’t help. Any idea how this could be fixed?

Again, thanks for the plugin, it’s great!


try replacing the samples all together. I built the plugin with my own samples (I didn’t like the originals) and never had this problem.
that is all I can think of.

This looks like a great plug-in, it would be really nice to see (as I haven’t found anything that does it yet) this have the ability to act as a trigger for Hydrogen (or some other drum synthesizer). Is that possible?

Maybe the trigger can act as a midi source and sends MIDI sequences to a sequencer (e.g. Hydrogen). As far as I can see LADSPA itself can’t handle any MIDI yet. But if I have some free time I will try to implement some JACK-MIDI interface which can be connected to Hydrogen for example. But I don’t know how the real-time behaviour would be. Maybe there is a lot of latency.

Not sure if latency would really be an issue, as long as it was constant. After bringing the track from Hydrogen back into Ardour, the track could be dragged back to where it needed to be.

It would be a little kludgy, but it would do the job.

check out dickmacinnis.com
I used this plugin for all the kick, snare and toms on the whole last album and it worked great, although when I compiled it I replaced the stock samples with some from the UltraAcoustic Kit, which is part of the Hydrogen-Drumkits package in ubuntu.

This plugin rocks ! I’ve been home-recording drums yesterday (with an edrums -> roland drum machine -> midi out / usb in -> hydrogen with default drumkit -> ardour), and I’ve replaced kick and snare with some samples from our latest studio recording. It worked very good.

Only the sample selection gui did not appear. So I had to create different presets, and then edit the xml file where the preset properties are stored to managed the different samples. Dunno where this bug is from.

ladspa cannot handle file selection, but is it possible to have a gui in ladspa (let say a simple button) that launches any kind of code, like a file chooser written in gtk ? It would be so cool to have a more usable ui. I’d love to have a “sample library” with the ability to select the replacement sample from there, and to add/remove sample to/from the library.

Another cool feature would be to be able to have more samples selected at once, and to randomly choose one at each replacement. It would help to “humanize” the result.

Again, you did an amazing job ! Thanks !

When compiling on mac…

beta 3 and current i get this message when compiling:

gregor-peytons-imac:ladspa-trigger 7 gregorpeyton$ sudo make
cc -I. -Iinclude -Wall -Werror -O3 -fPIC -fno-stack-protector -o src/trigger.o -c src/trigger.c
src/trigger.c:7:20: error: endian.h: No such file or directory
make: *** [plugins/trigger.so] Error 1

beta 1 and 2:

gregor-peytons-imac:ladspa-trigger 5 gregorpeyton$ sudo make
cc -I. -Iinclude -Wall -Werror -O3 -fPIC -fno-stack-protector -o src/trigger.o -c src/trigger.c
ld -o plugins/trigger.so -shared src/trigger.o
ld: unknown option: -shared
make: *** [plugins/trigger.so] Error 1

removing line “endian.h” from the “trigger.c” file from current and beta 3 i get the same message as beta 1 and 2.

there’s a binary package for ubuntu of this plugin on my website. See this post:

Oh, this looks very cool. I have been looking for something like this for linux.

well I’ve tried this plugin once again and there is some kind of “lag” between the input and the sample. I’ve downloaded the ladspa-trigger-alpha1 because it appeared to be newer than the beta version - is this my problem ?

The sourceforge screenshot shows a latency control - but I couldn’t find this.

Where is my problem with that ?

Has anybody else had any luck with a VST drum replacement plugin and linux ? I’ve tried 3 of the downloads from http://www.hometracked.com/2006/04/29/free-drum-replacers/ but none worked (they just crashed my ardour version).

Had anybody good experiences with those ?