Drum machine midi and soft synths

I’ve been following (as much as possible) the very snazzy video found here:

I have recorded the midi from a drum machine (a DR-880) in to a midi track in Ardour 3. I am attempting to use Specimen to apply sound to the midi notes the drum machine created. I have created the patches in specimen and I get sound when I click on the keyboard in specimen. I have assigned the patches in specimen to the notes of the midi on the ardour midi track.
I have connected specimen to ardour in the ardour midi connections and in the midi track’s input windows.
Not sure what I’m doing wrong… when I play back the midi notes from my midi track make no sound. The volume meter on the left-hand side of the tracks registers with every note, but no sound.
Please help me try to figure out what I’m missing.

Since Specimen is an external application, not a plugin, enter in Audio Settings in Specimen and specify “Sync to JACK Transport instead of MIDI”, and use JACK transport in Ardour instead of internal clock source, that did the job when i tried to do the same with Hydrogen.


Thank you for your reply. I checked, and I do have Specimen set for “Sync to JACK Transport instead of MIDI,” but can you please elaborate on “use JACK transport in Ardour instead of internal clock source?” I’m not sure I’m doing this correctly.

I found under Edit–>Preferences–>Transport the option for Sync/Slave External Timecode Source to toggle between Jack and other choices. Mine formerly was on MIDI Clock or Timecode and I switched it to JACK. Still no dice.

Additional info, which could help kind souls help me solve this is:
Ubuntu 12.10
Linux version 3.8.0-20-lowlatency
Ardour 3.1

Unfortunately, my Ardour 3 is a bit different from the one Dan MacDonald uses in his video.

@edisonbaggins: in the editor, take a look at the clock section, at its right should be a the clock source´s button, which is at “internal” by default and you will be able to see it says Internal even before clicking on it, it doesnt have any Icon, click on it and you will be able to change it to jack slave, hope that helps!

In my version of Ardour 3.1, the Internal/JACK toggle button is to the left of the time clocks. I toggled this to JACK, but no dice. It also makes the cursor behave kinda sporadic. Like it gets all warbly and won’t go back to start unless I tell it to several times.
This is just a guess at this point, but it seems as though Specimen is not getting a MIDI and/or audio signal from my Ardour MIDI track?
The master track is getting a signal from Specimen, as it’s level meter registers when I play a patch with Specimen and I hear the sample. Just, when I hit the cooresponding note at the MIDI track, no sound.

Specimen is not a sequencer, sync should be irrelevant here.I’D’s rather check again, if the notes are correct and sent via channels, that are configured in Specimen.

It was recommended to me to try using a plugin, instead of a stand-alone synth. I’m trying out samplv1, but I can’t figure out how to apply a different patch to various notes on the same Ardour MIDI track, e.g. a kick on C3, a snare on D3, a hi-hat on E3, shaker on F3, etc.
I can get one note to work, but if I try to load a 2nd note it switches everything on the track to the new note. Is this a limitation of samplv1? If so, is there a recommended plugin that can assign many different patches to the same track?
Thank you.

samplv1 is the wrong tool for the job, its meant for melodic samples such as a piano. The same author made drumv1 which should be more like what you are looking for. I haven’t used it so I can’t offer much beyond that. Alternatively you could create an sfz file which can be played through a couple different plugins, linuxsampler being the one I’m familiar with.

thank for the advice. drumkv1 is working nicely.