Dream beta release (Ubuntu Based Multimedia Distro with Ardour and ArdourVST 2.8.7)

The first Beta release of Dream is here! Dream is an Ubuntu based OS with multimedia content creators in mind. Dream’s goals are as follows:

  1. to stay in sync with Ubuntu’s regular releases (every 6 months)
  2. to have up-to-date packages of the software that matters most to multimedia content creators, including
    Ladspa and LV2 plugins
    Movie editing programs including Blender and Cinelerra
    Graphics programs including Inkscape, The Gnu Image Manipulation Program, Scribus, and many, many, fonts
  3. to offer a visually attractive alternative to other multimedia distributions (including matching themes for Ardour, GTK, QT, Cinelerra and others)
  4. to include custom kernels for use in multimedia by default (with both Realtime capabilities AND support for more than 4GB of RAM in one, stable distribution), along with default access to realtime capabilities by all users AND default connections between Pulseaudio and JACK (including JACK autostart by default)

Dream will be the easiest to try/install/upgrade, the most multimedia-centric, and the most current OS to come out of the FOSS world in a very short time, after which, it will be available at the same time as regular Ubuntu releases. As well, it will be easy to add to exising Ubuntu installations, portable (on USB sticks, VMs, via Wubi, etc…), and more configurable than any existing distribution.

To get in on the action early, download and install or try:
and update often, as new features will be added DAILY before Dream’s release in July of 2010.


I re-downloaded the beta1 image. It works, and I’ve got Dream installed on my computer. There are a few issues, though, but I’ll just send you an e-mail with those.

Did you ever release an iso for those without PAE support as claimed above? If so, what is the url?

check out dream.dickmacinnis.com. The default iso now ships with a generic kernel, which can easily be upgraded to either rt or rt-pae. Visit the new forum at the Dream Studio website for more information.

This looks like the distro I’m always waiting for. I think I will test it this weekend.


Hope you’re also building for us 64 bitters as well. This seems great! I have found that the attitude of Ubuntu to bug reporting leaves a lot to be desired…


Hi Dick, I create an account especially for this, but I hope it will make me play more with Ardour : )
I´ve just installed lucid a couple of days ago, so I will not install your ISO right now, but when I get the opportunity in another PC I will try it.
I’m curious about the installer, is like the Ubuntu installer? Or you used remastersys??
Besides that, my actual OS is similar to yours. I have pulsejack like a post-script in Jackcontrol, the little problem I found is that sometimes pulseaudio goes down and I need to ejecute the script in a terminal (without reinitializing Jack)

AK65: Unless you’re using more than 64GB RAM (I don’t know of a system that can even handle that), my distro will work just fine. Just install the rt-pae kernel (actually this is installed by default so you shouldn’t have to do anything), and it should work just fine. I will be releasing an iso for those without PAE support in time for stable release (anything above a P4 supports this architechture, and will work with both more than and less than 4GB RAM).
No need for 64-bit support unless you have more than 64GB RAM, in which case you probably have dual or more cores on your CPU, and in that case, Ardour will not take advantage no matter what system you’re using. Since 32bit is more stable (in Ubuntu at least), there is absolutely no reason to use 64bit unless you have more than 64GB RAM (which as I said earlier, is very, very, unlikely. And even if you DO use more than 64GB RAM, you probably know enough about computers to avoid linux/Ardour entirely.

No offense to Ardour devs, but multithreading in today’s world is far more important that RAM (given the amount of RAM one can pack into a single core machine vs. threading on the same machine with >2 cores)

I realize that Ardour3 is addressing these issues. As such, I will have an Ardour3 build ready for Dream/Ubuntu as soon as it is available as a stable release on these forums.


P.S. report all bugs with my distro to me (dick@dickmacinnis.com). That way, I can fix what is my problem, and forward upstream problems to the proper people ( as opposed to filing all bugs upstream ). Also, my pulseaudio->jack script (called pulsejack) seems to work well on my system , but let me know if it has problems, as stated above. And as far as AK65’s comments go: the fact that UbuntuStudio Dev’s don’t “respond/fix what you would want them to” is exactly the reason I started Dream to begin with ( and also because UbuntuStudio is even uglier that Ubuntu by default, if you can believe that ;-). I have joined the ubuntustudio-devel forum, irc chat, and left numerous feature requests, but to no avail. Their team seems to be either to busy (with other projects) to care, or only concerned with their own projects (which makes them appear either backward or terribly old fashioned. Reminds me of GCC devels.) Anyway, I WOULD like to thank UbuntuStudio for giving me a stable base to work from, and would also like to thank 64Studio and AVlinux for giving me a list of standard packages that people like to use, to choose from. I have both been inspired by, and expanded on all three of the aforementioned distributions.


Also to Captianmission: Install the following file:
and you will be able to get all the Dream packages for your standard Ubuntu Lucid install.

Also, it’s the same installer as Ubuntu. I used a combination of UCK and manual configuration, but my DVD is simply an expanded version of the standard Ubuntu, and in final release will also include a WUBI installer for windows users (it’s almost done right now).


Sorry, I forgot to mention, I´m JM Jones, I´ve already have your repos : )
Now I´m testing pulsejack in a RT kernel (I have both, Dream & RT ). In the standard Ubuntu kernel pulsejack goes down sometimes.

I have just installed Ardour/ubuntu hours ago and still have some problems. These are the following prompts I get when trying to start the audio engine.
Ardour could not start Jack.

  1. You selected audio parameters that are not supported. or
  2. Jack is running as another usrer.
    and also another prompt says:
    art shell not found-
    could not connect to Jack server as client. Overall operation failed.

metaldefektor: have you tried to start jack with qjackctl? If so, what does it say in the message window when you try to start jack?

i start qjacktl first then I run Ardour. the two error messages I get say Ardour may be running as another user -or- it says that I should try different parameters. I have rebooted my computer’s osl=/linux-ubuntu 3 times already and had managed to get the whole program running but for the life of me this time I can not.

On ubuntu 10.04 I couldn’t get reliable audio to work at all until I removed PulseAudio and added myself to the audio group. Adding yourself to the audio group might help fix problems with JACK not starting properly. The default settings for JACK used to be that it would start in ‘non-realtime’ mode which meant that even if you didn’t have the correct permissions or were not added to the right group, at least it would start even though there might be x-runs. Unfortunately the default JACK configuration seems now to be to try and start in realtime mode, which means that when ubuntu screw up the permissions again it just fails to start and you sometimes get strange messages from ardour or jack depending upon how you started them and in what order etc. In my experience PulseAudio is generally not compatible with a pro-audio setup either, and is best removed.


I couldn’t agree more, I also have a Lucid install here (it’s best to know the enemy…JK…lol) and my inaugural act was to immediately remove pulseaudio. Since AV Linux has never used pulseaudio I’m a little baffled why pulseaudio is needed in the first place, all the movie and music players don’t seem to care if it’s there or not and most of them will work with JACK if wanted. So why does there need to be any other audio server running when pretty much every major app will use ALSA or JACK? I’m curious to know, unless I’m missing something here.

All in all once you get Pulseaudio out of the picture Lucid is a really nice OS. I’m sure DreamOS takes it to the next level, Great Work Dick!

GMaq: the moment that someone wants sound from their web browser while their music player is also running is the moment that they discover why pulseaudio is useful.

@paul: not even sure about that.

I never used PA, just pure ALSA in general and never had problems with a player running concurrently with a youtube video or mythtv or another audio app with an ALSA backend.
I have lately patched this “ALSA only” environment to the jack graph in my DAW PC for precisely getting these apps useful on my RME based system. Just using the ALSA loopback virtual card and alsa_in / alsa_out was enough. alsa_in and alsa_out in this case have a similar purpose as the PA jack module sink and source.

It may look a bit hackish but it works cool for the limited purpose of straight playback and capture with an ALSA only app (aka non jackified app). I believe this bridge / patch thingy could turn out useful as well for prod boxes running jack with a firewire backend on a permanent basis.


I don’t understand why people are having so many issues with Lucid, I got jack to work realiably in realtime (with some setting up, of course not out of the box) without much trouble, and with pulseaudio enabled. The thing that I was missing was a proper rt-pae kernel, and the Dream repo is just what I needed! Thanks a lot!

@vervelover: "I got jack to work realiably in realtime (with some setting up, of course not out of the box) " That’s the key thing - “not out of the box” - I’m disappointed that some very simple things still don’t get configured properly. I was really hoping that by the time Ubuntu lucid was released it would provide a really good “straight out of the box” experience for people who want to try ardour and the frustrating thing is that it so nearly does… Obviously I realise that setting up a PC for pro-audio does require some tweaking - regardless of the OS - but it’s just such a shame that such great software as Ardour and the amazing work that goes into it can be undermined by some simple config issues not being right in the distro. In many cases the user just sees that Ardour doesn’t start - and I’m sure a percentage of would-be users give up at that point. It would be so good to never see any more "I can’t start JACK’ threads on this forum… :slight_smile: - JACK is such a great system for audio - I just want more people to be able to use it without having to edit config files (which keep changing location too!)…

As regards PulseAudio - I understand the issues it set out to address (and it does work for me sometimes - I used the lucid netbook remix on my netbook and it just worked…) - but its rare that it will co-exist happily for me with JACK. I never really found I needed it before it was invented… If that makes sense… On an old Mandriva 2007.0 box I can play mp3s, get sounds out of firefox and do all kinds of other audio stuff simultaneously just using ALSA - it just worked…)