Dragonfly Room verb attacked me last night

Hi Friends,
I opened a session last night in Ardour 6.2.0. I had my drum mix solo’d. Part of this mix includes one stereo buss with the Dragonfly Room reverb on it. On this session only my stereo overhead channel had an aux send to this verb.

Having worked on this session before and wanted to continue on, I pressed Play. Mixing on Sony 7506 headphones, I was treated to a deafening blast that sent my headphone drivers into physical distortion and almost sent my ears into temporary threshold shift. I was able to stop playback fast and immediately had silence. Whew!

With headphones off and my IO turned all the way down, I hit play again to see what nearly killed me. I found my drum verb buss strip slammed into the red.

I deleted the verb. Added it back in again. Recalled my verb settings. Pressed play again. This time all was back to normal.

For the record, I don’t mix loud. I don’t solo loud. In fact, I mix low, as that is how I produce mixes that hold together well. In other words, this is not the case of a late night rock mixing session where the levels get higher and higher. But I do set my IO monitor out such that I have plenty of headroom and do not eat up the master buss to quickly. What I experience was something gone way wrong.

I will reach out the the plugin team, but wanted to share this here as a warning. And, also, I’m asking for advice on what to do as far as troubleshooting to capture what is needed when something like this happens.

Yours,
-Steve

1 Like

You will probably want a limiter on the master bus from now on :slight_smile:

1 Like

This happens to me at times with Dragonfly Reverb too.
It’s really rare, and I have no idea how to reliably reproduce this problem so it’s difficult to debug :confused:

The same here . I had a project that did that every opening of it , but i finished it with another reverb
Cause it was really harmfull for my hears, really…

I dont even know if a limiter would be ok as the reverb was messing at the start, maybe quicker than the limiter could do?

I’ve had it happen with me in the past. I opened a ticket (https://github.com/michaelwillis/dragonfly-reverb/issues/37) and it was fixed for a while, but recently it started happening again. Might be worth posting on the ticket and reopening it.

Same here. I think the last time it happened while my headphones were lying on my desk which was a very good thing :slight_smile: Shame, because it is a fantastic reverb and shares first place in my collection with zita-rev1.

Wow. So, I’m not alone in this. Whew! I thought I was going crazy.

I did make an initial attempt to contact Michael Willis, but could not find any email link. I need to learn github.

Roberto, good idea. Thank you for the link. I’ll post to it and see what happens.

Thank you everyone for sharing.

-Steve

For the record, I was using lv2 V3.0.0 when this happened. I just installed v3.2.0. I wonder if the bug will be gone now?
I also posted on github for this too.

-Steve

Yep, happens in Mixbus too. Seems completely random but always happens on session open. Meters are pegged on the reverb bus. Quit the DAW and restart will clear it up until it randomly happens again.

If you have to use multiple instance of dragonlfy, this particular issue can be worked around by changing Ardour Preferences > General > Signal Processing use 1 core for DSP. – but that’s a rather drastic work-around.

I’m only using one instance in the entire session, on one bus. Not a concurrency issue here.

Hey everybody, I’m aware that this bug still exists in the latest version (3.2.0). If fact, it happened to me recently. I still do not know what causes it, and I can’t give any estimate of when it will be fixed.

@Michael_Willis, you have my permission to cease work on the animated dragonfly request and concentrate on this issue. Who knew beating wings at 170 Hz could generate master bus clipping? :wink:

I think I might be onto something - I haven’t experienced an explosion from the Dragonfly plugins for months, maybe even more than a year, but I do get the occasional bug report from somebody about a high-decibel blast of noise. Today I happened to use Ardour’s Shuttle Speed Control for the first time, and then later I got blasted by Dragonfly Room.

I’m wondering who here uses the Shuttle Speed Control. Also, @paul or @x42 Does Ardour’s plugin integration behave any differently when using this control, like changing the sample rate or the size of the input/output buffers passed to the plugin? I’m wondering if the Dragonfly Plugins behave badly when this control is being used.

Edit: Wow, I just reproduced it again. With the headphones on the desk, I started playing my current project in Ardour and kept moving the Shuttle Speed Control around. Dragonfly Room exploded in less than 60 seconds.

This indicates that the plugin currently requires a fixed block-size and cannot handle partial cycles.

When using vari-speed, or when looping or when automating a parameter, it is common that the plugin is called to process fewer samples than the nominal block-size.

The process cycle can be split: e.g. with a buffer-size of 256 the following may happen: process 17 samples, loop, process remaining 239 samples. The same happen on automation events. The plugin is asked to only process data until an automation-event occurs, which is not usually at cycle boundaries.

Vari-speed is also special. When playing at 90% speed the process-cycle is shortened. e.g. at 256 sample/period, the plugin will be asked to process 230 or 231 events instead of the nominal 256.

Another hint…

Ardour calls plugins to process data in-place (input buffers == output buffers). LV2 plugins that specify http://lv2plug.in/ns/lv2core#inPlaceBroken are currently not supported.

I recall that various freeverb calls expect a non-constant input buffer that are distinct from the output, and you first have to copy the input to the plugin to a temporary buffer (which could be on the stack).

Thanks for the hints, @x42. I think the Shuttle Speed thing was a red herring, since @serdeman just barely communicated on the Github issue that he experienced the bug immediately after opening an Ardour session with Dragonfly Room on a bus. However, it is a good hint that Ardour uses the same buffer for input and output. I either didn’t realize that or forgot; I’ll double check my source code and see if this might be a reason for this bug.

It would help if everybody here who has experienced this bug would please answer the following questions:

Which Dragonfly plugins do you use?
Have you experienced this bug recently? (Let’s say in the last six months)
Which plugin(s) exhibited the bug?
Do you run multiple instances of Dragonfly plugins in one project, or a single instance?
Which version of Ardour are you using?
What CPU do you have?

Which Dragonfly plugins do you use? All four
Have you experienced this bug recently? Yes
Which plugin(s) exhibited the bug? Hall
Do you run multiple instances of Dragonfly plugins in one project, or a single instance? Sometimes two, sometimes one
Which version of Ardour are you using? 6.2 (but I think I experienced the noise in 5.12, possibly 6.0)
What CPU do you have? AMD FX-6300

@robertodealmeida You say that it was fixed for a while, but recently started happening again. Do you know which version(s) of the plugins you were running that did not exhibit the bug? Do you know when it started happening again?