Does Ardour support WAV and MP3 files?

I apologize in advance for what surely must be a silly question, but I am left wondering if the absurdity is valid.

In Windows’ File Explorer, I right-click on a WAV or MP3 file then select “Open With” and choose Ardour.exe. But all I get is the New Session window that does not support standard audio files. Is there any way to have a GUI appear when the executable is selected, like Audacity and other DAWs?

In short: yes, Ardour support wav and mp3, but “open with” from the Windows Explorer does not work (Ardour should not even be listed there).

A session has to be created first, before any files can be imported. You can later import files using Menu > Session > Import, or via drag/drop from the Explorer to the timeline in Ardour’s Editor Window.

Hi Robin,
Thank you for your kind response and clarification.
If I may lean on you a little further, I would I like to know how to create a new session. I have tried many times but the main GUI never appears.
Also, can you see what is stopping me from posting at the forum? I can access my account but cannot post a question. Ardour seems to be a most unfriendly program. I must be overlooking something.
Thanks for lending a hand.

This is a copy/pasta from the class I teach at a university on it (Usually accompanied with a guided lecture). Technically it is on Mixbus but the same process applies to Ardour as well, and is slightly modified to hopefully edit things that won’t apply to you.

After that will be several dialogs for the initial setup of Mixbus on your computer. Suggested Settings follows for the various dialogs:

  1. Default folder for new sessions: Music (Anywhere is fine so long as you remember)
  2. Monitoring Choices: Ask Mixbus to play back material as it is being recorded

We will then be able to click where is says ‘New Session’ in a button to create a new session. For now we will use an Empty Template, but we will be going over how to create templates in the future.

The next dialog that opens will be your audio settings dialog. This is where you tell Mixbus what audio device you wish to use and the basic settings for your project.


  • Audio System - PortAudio
  • Driver - MME (Or ASIO if you have it)
  • Input Device - Varies, depends on the name of your sound card
  • Output Device - Same as above
  • Sample Rate - 48kHz
  • Buffer Size - 1024
  • Hardware Input Latency - Leave Alone
  • Hardware Output Latency - Leave Alone
  • MIDI System - WinMME

(OS X)

  • Audio System - CoreAudio
  • Input Device - Varies, depends on the name of your sound card
  • Output Device - Same as above
  • Sample Rate - 48kHz
  • Buffer Size - 1024
  • Hardware Input Latency - Leave Alone
  • Hardware Output Latency - Leave Alone
  • MIDI System - CoreMIDI

This will get your session set up. These will be the default settings we use in this class.

Press START and your new session should open. One Final Dialog may appear depending on your computer:

Screen Shot 2020-08-19 at 10.19.20 AM.png

In general you can tell Mixbus to select an appropriate mixer scale. This affects the size and spacing of some graphics of the mixer strip. We can always tweak this later in preferences.

Well technically you posted to the forum originally, and even though you replied via email to a notification, your post is still in the forum and is how I am replying to you currently. What are you doing to attempt to post in the forums, and what do you expect to happen vs what actually happens?


Evidently I had selected the wrong sound card. Your steps worked. Thank you soooooo much. But it would be nice to have the GUI appear firstly. The idea that each session must be configured seems laborious. But it’s a small price to pay for such a powerful program.

As for access to the forum, I learned that my effort to post was delayed by the administration, probably because I am new to the community.

Thanks again for your patience and kind help.

Well considering I am part of the administration, it wasn’t a manual process:). There is an automated timedown to prevent a mass spamming IIRC, so that may have been what you ran into.


It was put into auto-moderation. The reason was
“New user typed post very fast. This is likely a spam-bot”.
I suspected the text was copy/pasted, rather than typed, and have unblocked it.

Wow! You folks are clever. Yes, I did cut and paste my question as I firstly created it in a text editor for a record, in the event it got lost. Thanks for your understanding.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.