disk system was not able to keep up with Ardour

I don’t know if I have to put this message in the bug tracker or here. Sorry if it’s the wrong place.

I can’t export in wav with Ardour 3.0beta5 a one track session (2min) without efect.
I tried to change the playback buffer, and I obtain only a few seconds in the wav.
For example, if I choose 60 seconds for the playback buffer, I obtain a more o less 60 seconds of music in the wav file.
Once the buffer is empty, it seems not to fill it.
I have the message : “The disk system on your computer was not able to keep up with Ardour. Specifically, it failed to read data from disk quickly enough to keep up with playback.”

With Ardour 2.8.12, in the same configuration, no problems.

Jack version : 1.9.8
Tango Studio (Ubuntu 10.04 based),
linux kernel : 2.6.32-41-lowlatency
Gnome : 2.30.2
1G of RAM
My swap (2G) is on another hd than where I try to write the .wav
hdparm : Timing Cache Reads Timing 250 MB/sec Timing buffered disk reads 44MB/sec.

Should I change something in Ardour3 to have the same result than in Ardour 2.8.12 ?



Please file this as a bug in the bug tracker. Also, please try to visit the IRC channel sometime during US Eastern day time (UTC-5hrs) and ask for “las”. This is some seriously odd behaviour, and a web forum is the wrong context to try to track it down.

OK, thanks a lot for your answer.

I will try to fill the bug tracker.

I also will try to visit the IRC channel (I’ve never done that…) in the correct hours (I live in Spain!)