Disk can't keep up with ardour

Hello everybody,
I’m usingardour 2.8.14 on a Macpro core i7, with 6 GB of RAM, and 2 Lynx AES16e-50 PCI-Express cards, dealed with an aggregate device into core audio. Audio travels via 2 Cat 5e with 24 tracks on each card. The console ( midas PRO6 ) is the master for synchro.
My record disk is a SATA 7200 RPM. I have almost the same for system.

My problem is that when I want to record more than 25 channels, I have an error message telling me that " the disk can’t keep up with ardour ".
With another software, I can reach 32 channels without problem, and I would like to be able to reach 48 tracks with ardour.

What have I to do to reach this performance ? Is there a configuration in ardour to have ?
I turned the sample bitrate to 24 bits integer on place of 32 bits floating ( my computer receive 24 bits integer, so I don’t want change that ) to earn some place.
I turned the buffers to 512, but there is no result, anyway the system can reach a very short latency ( 64 buffers is default ).
I already have turned off the automatic backup of the ardour file.
Is there something else ? I’ve read in another post that someone had changed his “ardour rc” file. The solution may be there, but I can’t find the file in my home directory.
I’ve been told about software RAID on th internet, but when I tried it with linux, it didn’t worked, is ther the same for Mac OS ?
Thanks by advance.

Ok thanks seablade,
I’m gonna do this tomorrow when I will be at work, because for the moment I’ve just ardour3 on wheezy to have fun. ( seems great, works pretty good with my P4 ).

@agivagan: the only parameter you can alter that will affect this issue is only accessible in Ardour 2.X in a text file. Changing the audio processing buffer size will have no effect. The file is in question is $HOME/.ardour2/ardour.rc which OS X makes quite difficult to locate with the Finder. The variable is called “track-buffer-seconds” and it defaults to 5 seconds. Increasing it will provide more safety against slow disk I/O but it will make locating slower (since Ardour will have to read more data every time you locate to a new position on the timeline). For the record, this parameter is dynamically editable from the GUI of Ardour 3.

None of this addresses the fundamental problem. People have used disks slower than yours to get much higher track counts on an OS X system. What is the acoustic environment like where you are attempting to record? It is well known now that bass frequencies interfere with disk operations and create massively slower effective I/O bandwidth.

Thanks for your quick response Paul.

So, to locate the file I have to go with a console ? I’ll try that thursday, and will try to install ardour3 too. In OSX I tried also to eliminate things like auto update, and bluetooth.
For the vibration, actually we have some sound in the venue, but I have tested without sound, this morning, just recording "empty tracks to test it, so I think that the vibe is not in question there.


In Finder press SHIFT+COMMAND+G and it will ask you what folder you want to go to. Type in ~/.ardour2 and it will take you to the correct folder where you can find the file Paul mentioned. For the record I have mine at about 60 seconds for live tracking purposes, and when I track to a NAS box over Gigabit ethernet, tested up to 64 tracks without issue, may have gone higher it was some time ago.

Paul, you have verified that someone tracks more than 25 tracks on OS X without adjusting this value? I have NEVER done so, and highly recommend anyone that is doing higher track counts modify this value. Most people I know that deal with higher track counts this is true of to my knowledge. This is why I was excited to see it in A3 if you remember.


Hello again.
I came back lately on the mac.
Following the different advices, I turned the buffering at 60 seconds, both on 2.8.14 and on A3. Both stopped after a while, giving me many xruns, and telling me that “the disk can’t keep up with ardour”.
So I came back to 2.8.12 release, without changing anything other, and created a new session, ( on my system disk by error ), and it worked perfectly, with 48 tracks.
Actually, the problem seems to be in newer versions than the 2.8,12.
Of course I have suppressed the .ardour2 directory when I changed version. Now I’m recording wtih the “track-buffer-seconds” value=“5"” option, at 48 tracks, and it works.
Maybe it is some tweaks to do ? I precise that I have the last version of jack.
Thanks for reading.

it stopped, so I turned the buffers to 60 seconds again, and it works much better. So this tweaking has a real ipact on the recording. Thank you Seablade for the advice.
But I don’t understand why ardour doesn’t want to record with 2.8.14 and A3>>>

Hmm trying to remember,. I think my last tracking sessions were on older versions of Ardour, if you remind me I will see about doing a test tracking session with 2.8.14 to see if I can duplicate your problems here on OS X 10.7

When you want I can send you a copy of my session to have the same tweaks ( but I think it’s not useful, because sessions are almost default sessions.

Im using “60” and same disk problem, i have just 1 track and cant play it.

Macbook Pro with an external 7200rpm drive as my session disk

If you can’t play one track, you are having other problems. We would need to know much more, any error messages you are seeing, etc.