Disabling USB 3.0

Now this isn’t specific to ardour but I think there might be a good community of users here that could help. Feel free to suggest other places to ask this.

I have a Presonus 1818VSL which works very well on my desktop in a USB 2.0 port. On my laptop on the other hand with only USB 3.0 ports and an Ivy Bridge USB controller. It seems like the card cannot sync because there is intermittent playback and correspondingly intermittent Xruns in Jack. Windows users have experienced similar problems on Ivy Bridge USB 3.0 only systems. It seems that somewhere along the way Intel didn’t follow the USB spec and their controller is not capable of handling large packet streaming data well. They were aware of this but overlooked it since to thier opintion it wouldn’t affect too many users. Solutions so far have either disabled usb 3.0 support in BIOS (my bios menu has no such option), or uninstalled the intel xhci driver.

So basically I want my USB 3.0 ports to become USB 2.0. I have done a little reading suggesting that the kernel module xhci should be blacklisted and removed. However,

modprobe -r xhci returns:

FATAL: Module ehci not found.

And addiing blacklist xhci to the /etc/modprobe.d/blacklist.conf does not solve the problem.

Does anybody have any ideas on how I could get my USB 3.0 ports acting as though they were 3.0?

ehci-hcd is correct module name according kernel info for usb2.0
usb3.0 it’s xhci-hcd

Can you load the usb2 module?

modprobe ehci-hcd

This doesn’t seem specific to ardour, I think that you could get an answer from superuser.com or such. Sorry, I don’t know how to do this.


I haven’t been home with my lap top in a few days so I’ve been a bit slow. I learned a bit after my post that xhci was now named, xhci-hcd. I have tried removing the xhci module with modprobe -r but that returns an error message:

FATAL: Module xhci_hcd is builtin.

So I’ll give loading the ehci-hcd module a shot and see if that has any effect.

Otherwise I think I might be SOL. I would be curious to know if the Focusrite range has any problems with Intel’s USB controller. The feedback everyone is giving about the 18i6 is promisin, and I am curious if a similar ALSA patch could apply to the 18i20. Presonus is pointing the blame at Intel for not following the spec, but the built in interface that comes with my Digitech guitar pedal has no problems with it, although it doesn’t have to stream 18 channels of audio over the bus.


I have finally got things to work, although outside the OS. There was a setting in the BIOS called xHCI pre-boot, which I didn’t think would have an effect once in the OS that turned off xHCI support.

So for any of those possessing usb 3.0 only lap tops that want to use a Presonus 1818VSL in linux, it can be done. Just disable xHCI in BIOS.

Gotta love happy endings. :slight_smile:

I certainly do! Briging a nice thin little ultrabook to a mobile recording gig certainly beats my full desktop :slight_smile:

If anyone has any info on how to force USB 2.0 mode on USB 3.0 ports I’d love to know. I have the same problem with the 1818, but my Ivy Bridge laptop doesn’t have any USB options in the BIOS.