Disable Midi Thru

I always use hardware monitoring, so I know how to stop Ardour from performing ‘thru’ operations on audio tracks. But how do I similarly stop it performing a midi thru for midi tracks? I can’t find a setting for that. I am using external hardware monitoring of a midi controller, routing the controller to the sound module myself. The Ardour track has its input set to the controller and the output to the sound module, respectively for record and playback. But every note is sounding twice on the sound module, once in real time and once a few milliseconds later.

Thanks.

PS: I see this same question was raised in Jan 2016 under the heading ’ Ardour acts as MIDI thru ’ but the reply is not very helpful. It just says that the poster probably knows the answer, which is not the case in my case.

Thanks

It might help mentioning what platform, OS and version you are using and what your settings are. Like “is the MIDI channel armed, what do your MIDI connections look like, etc.”.

How is the sound module receiving doubled notes? Do you also have a connection directly from your MIDI controller to the sound module?

Sorry I did not mention my set up. I supposed this aspect of Ardour configuration was a generic question relevant to nearly all installations. I am using Ardour 6.2 on Fedora 31 with ALSA sequencer mode.

Yes, that’s right. I have a direct connection between my keyboard controller and my sound module synthesiser. This has approximately zero latency. I can make such a connection in several ways, such as using the qjackctrl patch bay or installing old 5-pin DIN midi cables and thru boxes. Also, if I had a standard MIDI keyboard synthesiser with internal connection between the keyboard and sound module parts, I’d surely be in the same situation? I wouldn’t want Ardour echoing everything I play after a few milliseconds or so.

I notice the thru behaviour stops when the channel is muted, so this is one work around: press mute before tracking some MIDI notes, and the unmute for playback. It’s a bit longwinded. Yes, it is armed as I recall. The MIDI connections are input from a USB Midi master keyboard and output to a another device: so both input and output are through ports listed in the ‘hardware’ division of Ardour’s MIDI patching window, rather than there being a softsynth instantiated within Ardour’s effects strip for the channel.

I do have a follow-up question as well, if you’d be so kind. I’ve been exploring the latency settings on the MIDI aspects of Ardour by performing various connections, such as recording the output of a 5-pin DIN connection on an audio input and recording (printing) the audio output of a Yamaha Motif controlled by USB midi. From this I’ve discovered that even with zero output advance on my MIDI output connection, the MIDI signal is 56 samples (1ms or so) too early. I attribute this to the default audio calibration, which by default, partitions the audio round trip precisely in two. So if I offset this partitioning, by moving 56 samples from one side to the other, I think it will be perfect. So that’s no problem. But on the MIDI input side, the amount of timing correction I need to apply seems to be a long way removed from what the ‘calibrate’ button on the MIDI Devices page suggests. Specifically I need to manually add on the “Buffer size” setting from the Audio/MIDI set up page. I presume this is a minor bug in this version of Ardour that simply fails to add this on. I am operating with Periods=2.

Many thanks - David Greaves

Yes. That’s it. Either mute the channel and “monitor directly” (with your ears and no DAW involved) or disconnect the controller from the synth. This is MIDI behaviour as it is excpected and the “echos” are two separate notes sent from two different devices.
Going any other way would cause you more trouble when playing back your recordings or overdubbing.

Dear Tom,

You seem to be saying that MIDI and Audio are different animals and it is sensible for them to behave differently. With audio, the disable monitoring function stops audio from being relayed through the DAW when using hardware monitoring, but the disable monitoring option does not affect MIDI in the same way. Perhaps that’s because this is not what’s expected by MIDI users? I certainly expected it to be the same, or at least for there to be an option for MIDI monitoring that mirrors what’s available for audio.

Anyway, I shall now stop searching for an element of functionality that does not exist.

Thanks v. much.

… And I think I’ve just realised that this behaviour makes any overdubbing or punch-in on MIDI tracks a bit more tricky, since the person or machine that is effectively pressing record has to also mute the channel at the same time…