Difficulty getting sound into Ardour

As of late, I’m having issues getting sound into Ardour. My audio interface is selected and levels are set correctly but I am not getting anything in Ardour.

Pavucontrol shows my inputs but no signal is detected from either my microphone or guitar.

I’m not sure if it’s related but when using Ardour the audio (from a web browser) on my system sounds choppy and I have to re-select my output device in order to remove the issue.

The choppy audio only occurs if any of the following are connected to playback_FL or playback_FR: Click/audio_out 1, Click/audio_out 1, Monitor/audio_out 1.

I’m using Ardour 6.9.0 on Arch Linux with Pipewire.

EDIT: Added screenshot

If that interface is usb check the usb cable with a new one…it is possible to show a connection that can’t carry a signal. True for all cables.

1 Like

I’ve just tried my audio interface on my laptop (Arch with Pipewire) and there’s no issues (no choppy audio, inputs work as they should etc).

I think the issue is now fixed. After plugging my audio interface back into my main system everything seems to be working as it should.

Before starting this topic I tried rebooting my system several times since I figured it was an issue with initialisation or something. Not sure why that didn’t fix it but reseating the cable did.

Thanks for the tip @Steve9600.

EDIT: The audio on my system dropped out and videos/audio from my web browser stopped loading. My audio interface was plugged into a KVM switch so I’ve plugged directly into my system. Hopefully there will be no more issues :crossed_fingers:

Plugging my interface into a usb hub was a on/off experience. And changing from a usb 2.0 to a 3.0 cable made a difference too ……no issues since even though the interface is a usb 2.0.

1 Like