Difference in sample rate in Ardour and JACK

My Jack is configured to work in 44.1KHz (M-Audio 2496) but the Ardour (was using 3.x, not sure about 2.x) was showing 48KHz on the top right area. Also when i drag-drop clips its telling me that the audio engine now is in 48KHz and should it proceed or not?

Is this expected? or any settings to be tweaked?

your interface may be one that only runs at 48kHz. JACK will not report an error when this is the case - we had several years of people complaining that it was stupid that they had to know the precise rate that their device could use - but will instead pick the nearest available one to the one you asked for (so 44.1kHz => 48kHz). From the command line the command jack_sample_rate will report on the current rate, and QJackctl also shows the value in its display (as does Ardour - so expect to see 48kHz everywhere).

i am using the M-Audio 2496 with Mudita24 mixer is set to use Smaple Rate = SPDIF and at the other end its the Focusrite/Scarlet 8i6 @ 44.1KHZ. SO if i change the 2496’s sample rate to 44.1 the Ardour should be showing it correctly?

no idea. i don’t know how this device and its driver responds to attempts to change the sample rate. what rate does jack_sample_rate report?

interestingly when i rebooted and checked with jack_samplerate it says 48 and the JACK ui syas 44.1 ! Then i just reselected the 44.1 in gui of JACK and saved it and restarted JACK and now the jack_samplerate reported 44.1 ! some glitch with JACK !

I’m also getting some new sample rate strangeness since upgrading from 3.0Beta5 to 3.1.

I created a few test songs in Beta5 a few months ago at 44.1K … my hardware has not changed since upgrading. Like earlier posters, I’m using an M-Audio 2496 which as far as I understand does support both sampling rates.

However, after installing version 3.1 and opening these older projects, Ardour informed me that Jack was running at 48k, but the songs were created at 44.1K. So, I stopped and started investigating the problem, which led me to this thread. I’ve run all the tests listed, and have uploaded a snapshot of the settings at the link below. You can see that in Alsa mixer, my M-Audio card is set to 44100, and the Jack Preferences also has the sample rate set at 44.1k, but when I start Jack, it reports 48000, and Ardour does as well.

I’ll jump into the IRC later, but if this is an easy and obvious fix, please let me know what to change.




A quick update since my issue was a simple one … thanks to PipeManMusic on IRC, we determined that I still had some jack processes running even after quitting the program. To discover the processes:

ps -A | grep jack

this returned two processes still running … To kill the processes:

killall -9 jack

Once I restarted jack, it set the sampling rate to match my interface (M-Audio 2496) @ 44.1k.



Might it be good for JACK to have a pop up asking if you would like it to work in the nearest possible sample rate rather than just doing it without warning?

@christophski: this is what JACK did for the first few years of its life, and it annoyed an equal number of people as the current behaviour, perhaps more.

Some of this is caused by the fact that JACK itself is not a GUI program and therefore any attempt to communicate “issues” to the user and ask for guidance is rather complicated (to put it mildly).