Despite Preferences, Ardour Projects automatically revert to previous signal routing configs

Before I say anything else I feel like I should give a huge thanks to the Ardour team for developing this great DAW as well as the regular forum members whose input have already helped me out a lot in learning my way around the software.
It’s been a blast so far, and I couldn’t be more grateful. Rock on, folks.


Anyway, that said, I have a small inconvenience I need to deal with every now and again.
(( System information is below, in case anything in there is relevant ))

The TL;DR is that Ardour (or perhaps it’s JACK? Claudia? etc?) will occasionally reconfigure the signal routing I’ve set for certain channels.
But for the sake of simplicity I think I’ll just lay out the scenario chronologically:

  1. Here I am, nearly a year ago, bright-eyed and excited to start using Ardour.
    I come up with a bunch of goofy or very simple names for new tracks, like “synth 1” or “bass” or “kick.” Pretty vanilla, nothing unusual yet.
    –> Except I have no idea yet how signal routing in software works, etc etc, so I take random channels and connect the inputs/outputs everywhere, just to experiment. I think we’ve all done this at some point. :wink:

  2. Fast forward a few months:
    Again, TL;DR, I know a little more about production In-The-Box, and no longer wantonly connect ins and outs all over kingdom come. Except, I notice that random tracks like “synth 1,” “bass” and “kick” and the like are automatically reconnecting to sources and destinations every time I add a new track, bus, send, insert, anything.
    –> Oh, side note: this is happening in every project. For example, if any kick in any one project has ever even touched output 4, I have to manually reconfigure it NOT to do so in the routing grid every time I add a new…anything, really.

  3. I figure out that Ardour (or maybe some other bit of software? Is that possible?) is somehow storing all my signal connections, and defaulting back to it under the conditions I’ve specified.
    –> I RTFM and ultimately find the preferences.
    “Okay,” I think to myself, "just go to ‘edit > preferences,’ and then go to ‘editor > signal flow’ and set all connections to “manual.”
    According to my preferences, track inputs and track/bus outputs are all set to manual.

  4. It’s still happening.
    Oh well, I’ll just delete and replace all the tracks and name them something that hasn’t been screwed up yet.

  5. Fast forward to now:
    It’s easy to make a wrong click every now and again, and I’ve now borked a few more tracks, and it’s just getting kind of irritating having to waste time with something so small. I ultimately shrugged and told myself it was time to figure out how to do it the right way.


So what’s going on here? How do I fix this? I’ve googled it and finnagled around on my own, but to no avail.
Kinda hate asking for help, but this is just obnoxious.

Some basic system info:
–> Running KXStudio, kernel version 3.13.0 (kxstudio prefers to lag behind a bit for stability), using Cadence as my JACK frontend, set to auto-start LADISH at login with a default studio, and I’m rocking Ardour 5.12.

Thanks for your time, guys. You’re the best.

Try it without ladish and see if it stops?

I haven’t known Ardour to do what your are describing.

Yeah, it happens with or without ladish.
Tried logging out/in just now to make sure. : /

Could it be that I’ve accidentally set some parameter incorrectly? I know the “session properties” menu has some option to ‘make these settings default.’

Hate to bump this, but this is still kind of an irritating problem. Any input, or is this just in the wrong forum?

It’s more likely that some other [JACK] session-manager or connection patchpay gets in the way. Can you try to reproduce this without JACK, using Ardour’s ALSA backend to confirm that it’s actually Ardour’s doing (stop jackd, claudia etc., launch Ardour & select Audio System: “ALSA” in the Audio/MIDI settings dialog)

Ah…wait, I lied.

Testing it more now, but it looks like JACK had been configured to “Don’t restrict self-connect requests.”

In case anyone else has this problem,
Configure jack from either Qjackctl or Cadence. Once you’re in the ‘settings’ menu, make sure you’re in the “engine” tab and look for “self-connect mode.”
JACK is likely defaulted to not restrict ‘self connections,’ so as soon as I selected “ignore all self-connect requests,” voila: all my routing was saved per-project, as I’d initially intended.

…hey, is there any way to mark this topic as “[solved]”? Not really seeing an ‘edit’ option here.

Sorry, just now saw your response. Seems you were right on the money. :v
Thanks, boss.

Nope. I lied again: NOW I can’t connect anything.

Working on it now.

Quick update:

The ‘problem’ is definitely the LADISH daemon. (Or at the very least, my mishandling of it.)
Experimenting jumping in and out of Ardour, restarting jack with different settings, etc etc…has kinda led me to the conclusion that Cadence is saving connections somehow.

Basically, Cadence offers the option to load your own default studio (your own preset patchbay connections) and I’d somehow saved almost every single connection I’d ever made, making the mistake that the only thing I’d been saving was the position of each jack port on the grid.
To undo previously made connections, you’d have to save the studio again after explicitly disconnecting whatever it is that keeps popping up automagically.

So far this seems to be solving my problems.

TL;DR:
–> Saving studios in cadence is a convenient way to hit the ground running.
–> Just be aware that it will auto-save any connections you make within JACK. I have yet to figure out how to turn this off.
–> If you do have troublesome connections that keep popping up, undo them and save again from within Claudia or something.

@Crackerjackthe4th Did you find a better solution meanwhile?

The solution to the re-connection problem is very simple: Don’t use Claudia, i.e. just start Jack in Cadence in don’t open / save any studio in Claudia. For manual connections only use the Jack Patchbay Catia instead.

1 Like

just start Jack in Cadence AND don’t open / save any studio in Claudia.

I had same problem and now this topic helped me.
Thank you so much.
Moreover I understood, at last, why Catia exists aside Claudia :slight_smile:

1 Like