default config when adding new tracks (M-Audio Audiophile 24/96 PCI, maybe FAQ?)

Howdy. Not sure if this is a FAQ or not but if so please point me at the appropriate spot and I will head there right away.

I recently setup Ardour 2 on a dedicated machine (thank you for the easy install path) though I have used Ardour 0.9* previously on an older gentoo installation. My sound card is an M-Audio Audiophile 24/96 PCI which has an ICE1212 (I think that’s the chipset, not at home right now) although only 4 of the potential inputs and outs are available. The Alsa driver for this card assumes that all are available regardless of whether they are which is no doubt why Ardour defaults (compliments of Jackd) to seeing all of these virtual channels.

Now when I start a new project from the default settings, the first tracks I add are associated with the expected first (real) stereo input on the card. If I add a second however, it automatically increments to the next set of inputs (i.e. 3 + 4) which aren’t actually connected (which took me a little bit to sort out). From experience adding mono tracks it looks like Ardour is just cycling through the available inputs each time I add a track.

I am wondering if there is a way to stop this behaviour and instead have Ardour by default associate a track with inputs 1 + 2? What I am wanting to have is an environment where I can right click to add tracks and have the default to the input set to either L1,R2 or for mono tracks 1+2 with the output sent to the master so I have monitoring capability during recording.

Any help here appreciated.


It’s all there.
read up on session configuration in the manual, section Input and Output Configuration.